helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Функция, определяющая наличие числа в строке

Код 1C v 8.х
 Функция ЭтоЧисло(Строка) // Экспорт

РезультатЭтоЧисло = 1; // Истина

ДлинаСтроки = СтрДлина(Строка);

Для i = 1 По ДлинаСтроки Цикл

Символ = Лев(Строка, 1);
Строка = Сред(Строка, 2);

Если Не (Символ = "1" Или Символ = "2" Или Символ = "3" Или Символ = "4" Или Символ = "5" Или Символ = "6" Или Символ = "7" Или Символ = "8" Или Символ = "9" Или Символ = "0") Тогда
РезультатЭтоЧисло = 0; // Ложь
Прервать;
КонецЕсли;

КонецЦикла;

Возврат РезультатЭтоЧисло;

КонецФункции // ЭтоЧисло
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 6244
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.