helpf.pro
Регистрация
 +3 
Распечатать

1С 8.x : Как подключиться (присоединится) к базе 1С 8 через СОМ

Код 1C v 8.х
 //Пример 1 
v8 = CreateObject("V8.COMConnector");
//Строку подключения можно получить так:
Если ФайловаяБазаДанных Тогда
СтрокаПодключения = "file='" + КаталогБазыДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "';";
Иначе
СтрокаПодключения = "srvr='" + Сервер + "'; ref='" + БазаДанных + "'; usr='" + Пользователь + "'; pwd='" + Пароль + "';";
КонецЕсли;
Попытка
//Соединение = V8.Connect("Usr=""admin"";Pwd="""";File=""\\srvr\1C\V8\UPP""");
Соединение = V8.Connect(СтрокаПодключения);
Исключение
Сообщить(ОписаниеОшибки());
КонецПопытки;


//Пример 2
Функция ОткрытьСоединение(ОписаниеОшибки) Экспорт
СтрокаПодключения = СформироватьСтрокуПодключения();
Connector = Новый COMОбъект("V8.ComConnector");

Попытка
DataSource = Connector.Connect(СтрокаПодключения);
Исключение
ОписаниеОшибки = ОписаниеОшибки();
КонецПопытки;

Если DataSource = Неопределено И ПустаяСтрока(ОписаниеОшибки) Тогда
ОписаниеОшибки = "Неизвестная ошибка подключения к 1С:Предприятие 8.0";
КонецЕсли;

Если Не ПустаяСтрока(ОписаниеОшибки) Тогда
DataSource = Неопределено;
Connector = Неопределено;
КонецЕсли;

Возврат DataSource;
КонецФункции

Функция СформироватьСтрокуПодключения()

СтрокаПодключения = "";
Если ЭтоСервер Тогда
СтрокаПодключения = СтрокаПодключения + "Srvr=" + Сервер + ";Ref=" + Имя + ";";
Иначе
СтрокаПодключения = СтрокаПодключения + "File=""" + Сервер + """;";
КонецЕсли;
СтрокаПодключения = СтрокаПодключения + ?(ПустаяСтрока(Пользователь), "", "Usr=""" + Пользователь + """;");
СтрокаПодключения = СтрокаПодключения + ?(ПустаяСтрока(Пароль), "", "Pwd=""" + Пароль + """;");

Возврат СтрокаПодключения;
КонецФункции

Посмотрите еще ответ на вопрос: Как определить Информационная База файловая или SQL?
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 37134
 +3 
Распечатать
Возможно, вас также заинтересует
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
База для Разработки или Рабочая? Как быстро определить? 1
Когда-то я работал консультантом SAP . В SAPe есть настройка изменения цвета главного окна программы и у нас было негласное правило: Рабочая программа - Красный фон , Тестовая - Зеленый , Разработка - Синий . Работая в 1С,...
Был ли изменен документ? 0
// Модифицированность() - Определяет, был ли изменен объект после считывания из базы данных. // НО Метод не позволяет определить, был ли изменен объект другими пользователями. Если Модифицированность() тогда ...
Был ли изменен элемент справочника? 0
// Модифицированность() - Определяет, был ли изменен объект после считывания из базы данных. // НО Метод не позволяет определить, был ли изменен объект другими пользователями. Если Модифицированность() тогда ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.