helpf.pro
Регистрация
 +1 
Распечатать

1С 8.x : Автоматическая выгрузка загрузка данных используя регламентное задание

Для обмена данными между программами необходимо сделать следующее:
1. При помощи Конвертации Данных создать правила выгрузки данных
2. Нужно чтобы в конфигурации была обработка УниверсальныйОбменДаннымиXML, желательно последней версии!
(При помощи ее и созданных правил будут выгрузаться и заружаться данные)
3. В 1-вой базе Добавляем Регламентное задание:
Имя - Выгрузка
Использование - !(галочка)
Расписание настройте обязательно.
Имя метода - Общий модуль в котором процедура ВыгрузимИзЗУП():
Код 1C v 8.х
 //Выгрузка кадровых данных
Процедура ВыгрузимИзЗУП() Экспорт
Обработина = Обработки.УниверсальныйОбменДаннымиXML.Создать();
Обработина.РежимОбмена = "Выгрузка";
Обработина.ДатаНачала = НачалоДня(ДобавитьМесяц(ТекущаяДата(),-1));
Обработина.ДатаОкончания = КонецМесяца(ТекущаяДата());
Обработина.ИмяФайлаОбмена = "D:\ZUP_BUH_EXCH\Upload.xml";
Обработина.ИмяФайлаПравилОбмена = "D:\ZUP_BUH_EXCH\Zup-Buh.xml";
Обработина.ЗагрузитьПравилаОбмена();
Обработина.ВыполнитьВыгрузку();
КонецПроцедуры


4. Во 2-ой базе Добавляем Регламентное задание:
Имя - Загрузка
Использование - !(галочка)
Расписание настройте обязательно.
Имя метода - Общий модуль в котором процедура ЗагрузкаВБУХ():
Код 1C v 8.х
 Процедура ЗагрузкаВБУХ() Экспорт	
Обработина = Обработки.УниверсальныйОбменДаннымиXML.Создать();
Обработина.ИмяФайлаОбмена = "D:\ZUP_BUH_EXCH\Upload.xml";
Обработина.РежимОбмена = "Загрузка";
Обработина.ОптимизированнаяЗаписьОбъектов = Истина;
Обработина.ЗаписыватьРегистрыНаборамиЗаписей = Истина;
Обработина.ЗаписыватьВИнформационнуюБазуТолькоИзмененныеОбъекты = Истина;
Обработина.ЗагружатьДанныеВРежимеОбмена = Истина;
Обработина.ВыполнитьЗагрузку();
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 19626
 +1 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.