helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Как самостоятельно заполнить дерево значений?

Код 1C v 8.х
 Процедура ЗаполнениеДерева(Кнопка) 
Дерево.Колонки.Очистить();
Дерево.Колонки.Добавить("ИмяКолонки");

// Создать первую строку. Правильнее сказать создать элемент
// коллекции. Он помещается в переменную "СтрокаВерхнегоУровня".
СтрокаВерхнегоУровня = Дерево.Строки.Добавить();

// В колонку "ИмяКолонки" записать значение "Старшая".
СтрокаВерхнегоУровня.ИмяКолонки = "Старшая";

// Создать строку подчиненную "Старшей".
ПодчиненнаяСтрока =СтрокаВерхнегоУровня.Строки.Добавить();
ПодчиненнаяСтрока.ИмяКолонки = "Первая подчиненная";

ПодчиненнаяВторогоУровня = ПодчиненнаяСтрока.Строки.Добавить();
ПодчиненнаяВторогоУровня.ИмяКолонки = "Первая нижняя";

ПодчиненнаяВторогоУровня = ПодчиненнаяСтрока.Строки.Добавить();
ПодчиненнаяВторогоУровня.ИмяКолонки = "Вторая нижняя";

ПодчиненнаяСтрока = СтрокаВерхнегоУровня.Строки.Добавить();
ПодчиненнаяСтрока.ИмяКолонки = "Вторая подчиненная";

// Использование метода позволит увидеть результат работы
// с деревом значений в табличном поле.
ЭлементыФормы.Дерево.СоздатьКолонки();

КонецПроцедуры

Процедура ОткрытиеВетки(Кнопка)

// Сделать текущим именно элемент коллекции "Строки".
РезультатПоиска = Дерево.Строки.Найти("Первая нижняя", "ИмяКолонки", Истина);

Если РезультатПоиска <> Неопределено Тогда
ЭлементыФормы.Дерево.ТекущаяСтрока = РезультатПоиска;
КонецЕсли;

КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 22916
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.