helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Открыть форму выбора и выбрать элемент справочника

На форме отчета находится поле списка, связанное с реквизитом списком значений.
Нужно:
1) чтоб при нажатии на кнопку Подбор на форме отчета открывалась форма справочника
2) при выборе элементов этого справочника они попадали в список значений в форме отчета и отображались в поле списка.
Как это сделать?


Код 1C v 8.х
 // сзВодители - тот самый список значений,
// Справочники.Водители - справочник, откуда надо добавлять данные в список

// Кнопка Подбор:
Процедура ДобавитьВодителяНажатие(Элемент)
ФормаПодбора = Справочники.Водители.ПолучитьФормуСписка(,ЭтаФорма);
ФормаПодбора.РежимВыбора = Истина;
ФормаПодбора.ЗакрыватьПриВыборе = Ложь;
Если Не ФормаПодбора.Открыта() Тогда
ФормаПодбора.Открыть();
КонецЕсли;
КонецПроцедуры

// ОбработкаВыбора для формы со Списком Значений
Процедура ОбработкаВыбора(ЗначениеВыбора, Источник)
сзВодители.Добавить(ЗначениеВыбора, ЗначениеВыбора.Наименование, Истина);
КонецПроцедуры

Как видите, владельцем формы, открываемой для подбора служит не отдельный элемент формы отчета, а вся форма отчета.
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 12268
 0 
Распечатать
Возможно, вас также заинтересует
Microsoft SQL Server Native Client Добавление значения в столбец "datetime" привело к переполнению 0
При формировании отчета на СКД получили ошибку: Microsoft SQL Server Native Client 11.0: Добавление значения в столбец "datetime" привело к переполнению Подробнее текст такой: ... по причине: Ошибка компоновки данных по причине: Ошибка...
Автоматизация обмена данных используя обработку "Универсальный обмен данными в формате XML" 3
Автоматизация обмена между базами используя обработку " Универсальный обмен данными в формате XML" В основу данной публикации положены найденные мною материалы по cозданию обмена между двумя базами с использованием ...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Был ли изменен элемент справочника? 0
// Модифицированность() - Определяет, был ли изменен объект после считывания из базы данных. // НО Метод не позволяет определить, был ли изменен объект другими пользователями. Если Модифицированность() тогда ...
В отчет не попадают данные за последний день… Как исправить? 0
Пользователь выбрал период формирования отчета с 1июля по 31. Почему при формировании отчета в него не попадают данные за 31 число? На самом деле, это одна из самых распространенных ошибок при разработке отчетов. В 1С 8.х...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.