helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Отправка sms из 1C через avisosms.ru.

Столкнулся с задачей отправки sms из 1С. Спасибо Якову за напутствие в решении данной задачи и указание сервиса avisosms.ru.

На сайте сервиса предоставлена документация по работе с ним. В частности сервис предлагает следующие варианты работы:
* JSON протокол
* email2SMS протокол
* HTTP GET протокол
* Удаленный доступ к телефонной книге
* XML протокол

После проб и ошибок с протоколом email2sms (ну не любит мой провайдер через smtp слать письма на не очень красивые адреса относя их к спаму и блокируя) был выбран вариант решения с JSON протоколом. Для краткой демонстрации работы сервера приведена небольшая конфигурация. Конфигурация написана на 1С Предприятие 8.2 с поддержкой работы веб-клиента. Для работы конфигурации необходимо заполнить константы:
* ПользовательСМС – Ваш логин в систему;
* ПарольСМС – Ваш пароль в систему;
* ПодписьСМС – Ваш адрес отправителя, который был создан в личном кабинете.

Конфигурация позволяет:
* Отправлять смс контрагенту, номер которого записан в соответствующем реквизите (номер пишем в формате 380ХХХХХХХХХХ);
* Получать статусы отправленных смс.

Ниже приведу код формирования запроса на отправку смс
Код 1C v 8.2 УП
 &НаСервере
Функция ОтправитьСервер()
УспешнаяОтправка = Ложь;
ПараметрJSON = "{'username': '" + Константы.ПользовательСМС.Получить() + "'";
ПараметрJSON = ПараметрJSON + ",'password': '" + Константы.ПарольСМС.Получить() + "'";
ПараметрJSON = ПараметрJSON + ",'request_type': 'send_message'";
ПараметрJSON = ПараметрJSON + ",'destination_address': '" + Объект.Контрагент.НомерТелефона+ "'";
ПараметрJSON = ПараметрJSON + ",'message': '" + Объект.ТекстСМС+ "'";
ПараметрJSON = ПараметрJSON + ",'source_address': '" + Константы.ПодписьСМС.Получить() + "'";
ПараметрJSON = ПараметрJSON + ",flash:'0'}";

Попытка
WinHttp=Новый COMОбъект("WinHttp.WinHttpRequest.5.1");
WinHttp.Option(2,"Windows-1251");
WinHttp.Open("POST","http://api.avisosms.ru/sms/json/",0);
WinHttp.SetRequestHeader("Accept-Language", "ru");
WinHttp.SetRequestHeader("Accept-Charset","Windows-1251");
WinHttp.setRequestHeader("Content-Language", "ru");
WinHttp.setRequestHeader("Content-Charset", "Windows-1251");
WinHttp.setRequestHeader("Content-Type","application/x-www-form-urlencoded; charset=Windows-1251");
WinHttp.Send(ПараметрJSON);
ТекстОтвет = WinHttp.ResponseText();
Если Найти(ТекстОтвет, "OK_Operation_Completed") Тогда
УспешнаяОтправка = Истина;
КонецЕсли;
Исключение
Сообщить("Ошибка соединения:");
Сообщить(ОписаниеОшибки());
КонецПопытки;

//Запись отправленной смс в историю
Если УспешнаяОтправка Тогда
ПозицияКодаНачало = Найти(ТекстОтвет, "messageId") + СтрДлина("messageId")+3;
ПозицияКодаКонец = Найти(ТекстОтвет, "}");
КодСМС = Сред(ТекстОтвет, ПозицияКодаНачало, ПозицияКодаКонец-ПозицияКодаНачало-1);

СМСРассылка.ЗаписатьСМСВИсторию(Объект.Контрагент, Объект.ТекстСМС, КодСМС);
Иначе
Сообщить("Отправка смс не состоялась. Текст ошибки: " + ТекстОтвет);
КонецЕсли;
Возврат УспешнаяОтправка;
КонецФункции


Источник
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 13159
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Microsoft SQL Server Native Client Добавление значения в столбец "datetime" привело к переполнению 0
При формировании отчета на СКД получили ошибку: Microsoft SQL Server Native Client 11.0: Добавление значения в столбец "datetime" привело к переполнению Подробнее текст такой: ... по причине: Ошибка компоновки данных по причине: Ошибка...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.