helpf.pro
Регистрация
 0 
Распечатать

1С 8.x : Пересчет дерева, суммы и коэффициенты.

Код 1C v 8.х
 //Находит строку и начинает пересчет вверх по узлам.
Процедура ПересчитатьВсеДерево(дз_стр)
для каждого стр из дз_стр.Строки Цикл
Если стр.строки.количество()>0 тогда
ПересчитатьВсеДерево(стр);
Иначе
ПересчетСуммДерева(стр);
прервать;
КонецЕсли;
КонецЦикла;
Конецпроцедуры

Процедура ПересчетСуммДерева(ТекСтрока)
Родитель=ТекСтрока.Родитель;
Если Родитель=Неопределено Тогда
Возврат;
КонецЕсли;
родитель.НазначенныйФонд=родитель.Строки.Итог("СуммаЧегото");
родитель.КТУ=Формат(родитель.Строки.Итог("СреднийПроцентДляУзлов")/Родитель.Строки.Количество(),"ЧДЦ=2");
ПересчетСуммДерева(Родитель);
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 10324
 0 
Распечатать
Возможно, вас также заинтересует
В ЗУП не исчисляются суммы районного коэффициента и северной надбавки? 1
В Зарплата и управление персоналом 8 почему при расчете среднего заработка для начисления очередного отпуска не исчисляются суммы районного коэффициента и северной надбавки? При исчислении среднего заработка во...
Ввод данных по командировкам в программе ЗУП 0
Ввод сведений о командировках в программе 1С: Зарплата и управление персоналом 8 (ред.30) осуществляется в Разделе Кадры - Все кадровые документы - Создать - Командировка Откроется документ: Ввод сведений о...
Документ "Корректировка записей регистров" - Как программно создать и заполнить? 2
Документ «Корректировка записей регистров» в типовых конфигурациях 1С предназначен для ручной корректировки записей регистров накопления, зависимых регистров сведений и регистров бухгалтерии. Типичные ситуации, в...
Изменился тариф почтового сбора. Как его внести в программу ЗУП? 0
Согласно новому тарифу почтового сбора для Московской области при размере перечисляемой суммы от 1000 руб. до 5000 руб. включительно сбор рассчитывается по формуле: (50 руб. + 4% от суммы) + (1,5 % от суммы свыше 1000 руб.) Эта...
Использование предложения ДЛЯ ИЗМЕНЕНИЯ 0
Предложение ДЛЯ ИЗМЕНЕНИЯ позволяет заблаговременно заблокировать некоторые данные (которые могут читаться транзакцией другого соединения) уже при считывании, чтобы исключить взаимные блокировки при записи. ДЛЯ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.