helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Определение пола по имени

Функция проверяет уже существующих в базе данных людей на наличие требуемого имени.
Во время поиска следует учитывать следующие ситуации:

1) Вместо имени записаны инициалы
2) Существуют имена, которые могут быть как мужскими, так и женскими (например, Саша)

На второй пункт можно возразить: следует писать полное паспортное имя, а не уменьшительное. На самом деле это не всегда удобно, особенно во время большого потока людей или же, например, при работе с иностранными именами.

Код 1C v 8.х
 Функция ОпределитьПол(Имя) Экспорт

Если СтрДлина(Имя) > 1 Тогда
Запрос = Новый Запрос("
|ВЫБРАТЬ
| П.Пол КАК Пол
|ИЗ
| Справочник.Пациенты КАК П
|ГДЕ
| ВЫРАЗИТЬ(П.Имя КАК СТРОКА(100)) = ВЫРАЗИТЬ(&Имя КАК СТРОКА(100))");
Запрос.УстановитьПараметр("Имя",Имя);
Результат = Запрос.Выполнить().Выгрузить();

М = 0;
Ж = 0;
Для Каждого Строка Из Результат Цикл
Если Строка.Пол = Перечисления.Пол.Мужской Тогда
М = 1;
КонецЕсли;
Если Строка.Пол = Перечисления.Пол.Женский Тогда
Ж = 1;
КонецЕсли;
КонецЦикла;

Если (М = 1) И (Ж = 0) Тогда
Возврат Перечисления.Пол.Мужской;
КонецЕсли;
Если (М = 0) И (Ж = 1) Тогда
Возврат Перечисления.Пол.Женский;
КонецЕсли;
КонецЕсли;

КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9412
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-соединение не обнаружило свободной лицензии / ключ защиты 0
Иногда при подключении к 1С возникает ошибка: COM-соединение не обнаружило свободной лицензии! COM-соединение не обнаружило ключ защиты программы! https://helpf.pro/uploads/img/_1-UsuyAg6E2P.jpg В таких случаях, иногда, может помочь...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
V82.COMConnector.1: Не найдена лицензия COM-соединением 1
При подключении из одной базы к другой через COM внезапно стала появляться следующая ошибка: «V82.COMConnector.1: Не найдена лицензия COM-соединением», хотя никаких изменений на серверах не делалось. Релиз платформы был 8.2.13....
ZIP-архив Разделить и Объединить Файл 0
При работе с большими объемами данных могут возникнуть проблемы при пересылке архивных файлов. Типичной такой ситуацией является ограничение некоторых почтовых серверов на размер сообщения - если письмо превышает...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.