helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Функция проверяет номер страхового свидетельства на соответствие требованиям ПФР

Проверка контрольного числа Страхового номера проводится только для номеров больше номера 001–001–998
Контрольное число Страхового номера рассчитывается следующим образом:
• каждая цифра Страхового номера умножается на номер своей позиции (позиции отсчитываются с конца)
• полученные произведения суммируются
• сумма делится на 101
• последние две цифры остатка от деления является Контрольным числом.
Например: Указан страховой номер 112–233–445 95
Проверяем правильность контрольного числа:
цифры номера 1 1 2 2 3 3 4 4 5
номер позиции 9 8 7 6 5 4 3 2 1
1х9+1х8+2х7+2х6+3х5+3х4+4х3+4х2+5х1=95
95 / !101! =95
Контрольное число=95 – указано верно
Некоторые частные случаи:
99 / !101! =99
100 / !101! =00
101 / !101! =00
102 / !101! =01
Код 1C v 8.х
 //Проверяет номер страхового свидетельства на соответствие требованиям ПФР
Функция СтраховойНомерПФРСоответствуетТребованиям(СтраховойНомер) Экспорт

Результат = Истина;

СтрокаЦифр=СтрЗаменить(Лев(СтраховойНомер,11),"-","");

Если ПустаяСтрока(СтрокаЦифр) Тогда
Возврат Ложь;
КонецЕсли;

Попытка
П1 = Число(СтрокаЦифр);
КонтрольноеЧисло=Число(Прав(СтраховойНомер,2));
Исключение
Возврат Ложь;
КонецПопытки;

Если Число(Лев(СтрокаЦифр,9)) > 1001998 Тогда
Всего=0;
Для Сч = 1 По 9 Цикл
Всего=Всего+Число(Сред(СтрокаЦифр,10-Сч,1))*Сч
КонецЦикла;
Остаток=Всего%101;
Остаток=?(Остаток=100,0,Остаток);
Если Остаток<>КонтрольноеЧисло Тогда
Результат = Ложь;
КонецЕсли;
КонецЕсли;

Возврат Результат;

КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 8272
 0 
Распечатать
Возможно, вас также заинтересует
Загрузить данные в 1с из текстового файла с разделителями 1
В этой статье я расскажу, как загружать данные в 1с 8 из простейших текстовых файлов с разделителями. Обычно они имеют расширение csv (Comma-Separated Values). Т. е. название подразумевает, что в каждой строке такого текстового файла...
Значение поля "Код" не уникально или Значение поля "Номер" не уникально 0
При работе в 1С, особенно когда много документов или номера редактируются ручками, можно получить ошибки вида: Значение поля "Код" не уникально или Значение поля "Номер" не уникально Что делать? Перенумеровывать :) ...
Как в 1С отразить проводки по начислению и уплате страховых взносов ООО и ИП за себя? 0
Проводки по начислению и уплате страховых взносов ИП за себя формируют квартальные регламентные операции по закрытию месяца. Если вы хотите ввести сами, то: Операции - Операции, введенные вручную , через 69.06 - Расчеты...
Как в программе 1С Бух 3 отразить начисление фиксированных страховых взносов ИП? 1
Порядок расчета фиксированных страховых взносов за 2014 и 2015, 2016 год Сумма взноса в ПФР = МРОТ * 12 * 26 % Сумма взноса в ФОМС = МРОТ * 12 * 5.1 % где МРОТ (Минимальный Размер Оплаты Труда): 5554 рублей в 2014 году 5965 рублей в 2015
Как по Номеру Недели Года получить Дату 0
//Как из номера, числа недели вернуть первую Дату этой недели? Функция ДатаПоНомеруНедели(НомерНедели, Год = Неопределено) Возврат НачалоНедели(Дата(?(Год=Неопределено, Год(ТекущаяДата()),...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.