helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как определить при добавлении нового справочника, что он добавляется копированием?

Код 1C v 8.х
 // В Процедуре ПриОткрытии()
Если ЭтоНовый() Тогда
Если НЕ ПараметрОбъектКопирования = НЕОПРЕДЕЛЕНО Тогда // Проверка на копирование
Предупреждение("Запрещено копировать Договора!");
Закрыть();
КонецЕсли;
КонецЕсли;


Подробнее:
Есть расширение формы документа ПараметрОбъектКопирования. В него при копировании помещается ссылка на документ оригинал.
Также есть расширение ПараметрОснование, в нем ссылка на основание.

Вот пример:
Код 1C v 8.х
 Процедура ПриОткрытии()

Если ЭтоНовый() Тогда

Если ПараметрОбъектКопирования = НЕОПРЕДЕЛЕНО Тогда
// заполняем реквизиты значениями по умолчанию
...

Иначе
...
КонецЕсли;
...

КонецЕсли;
...

КонецПроцедуры


Еще при копировании возникает событие ПриКопировании (OnCopy)
Синтаксис:
ПриКопировании(<ОбъектКопирования>)
Параметры:
<ОбъектКопирования>
Тип: СправочникОбъект.
Исходный элемент, который является источником копирования.
Описание:
Возникает при создании элемента справочника копированием.
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 8202
 0 
Распечатать
Возможно, вас также заинтересует
Ввод дополнительного ежегодного отпуска 0
Вид расчета, используемый для начисления оплаты дополнительного ежегодного отпуска , описывается в плане видов расчета Основные начисления организаций . Новый вид расчета удобнее создать копированием...
Выгрузка в PDF из 1С (Средствами OpenOffice) 0
Возникла задача отправлять счета почтой. PDFcreator не подошел поскольку не удалось вместить счет на одну страницу по ширине. Решил попробовать OpenOffice. Как сохранять в PDF нашел быстро, а вот как уместить счет на одну страницу...
Выгрузка из 1С на SFTP 0
Думаю, что все знают, как работает 1с с FTP сервером, но вот как работать с sFTP или FTPs сервером? Первое что Вам нужно сделать - это установить бесплатную программу WinSCP, скачать ее Вы сможете здесь, также там есть вся...
Выгрузка форматированного документа 1С на свой сайт 0
Пользователи в 1с ведут описание объектов, которые редактируются в объекте ФорматированныйДокумент. Необходимо обеспечить выгрузку форматированного документа на фтп. Для решения этой задачи воспользуемся методом...
Где находится файл лицензии 1С 9
Многие спрашивают А где хранится лицензия на 1С: Предприятие 8? или Где посмотреть лицензионный ключ в 1С? В 1С информацию о полученной лицензии можно посмотреть нажав «Справка» — «О программе» В разделе Лицензия:...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.