helpf.pro
Регистрация
 +1 
Распечатать

1С 8.2 УП : Как получить сальдо дебетовое или кредитовое?

Примеры универсальных функций 1С для получения Конечных Сальдо Дк и Дт:
Код 1C v 8.х
  //Перед использованием укажите значения переменных:
знОрганизация = Организация;
КонПериода = ТекущаяДата();

// СКД - Сальдо Конечное Дебетовое
Функция СКД(Счет, ДатаО = Неопределено)
Если ДатаО = Неопределено Тогда ДатаО = КонецДня(КонПериода) КонецЕсли;
СчетПЛ = ПланыСчетов.Хозрасчетный.НайтиПоКоду(Счет);
Если СчетПЛ = ПланыСчетов.Хозрасчетный.ПустаяСсылка() Тогда
Возврат "Нет счета!";
КонецЕсли;
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ХозрасчетныйОстатки.СуммаОстатокДт,
| ХозрасчетныйОстатки.СуммаОстатокКт
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(&DatO, Счет В ИЕРАРХИИ(&Scet), , Организация = &Organ) КАК ХозрасчетныйОстатки
|";
Запрос.УстановитьПараметр("DatO", Новый Граница(ДатаО, ВидГраницы.Включая));
Запрос.УстановитьПараметр("Scet", СчетПЛ);
Запрос.УстановитьПараметр("Organ", знОрганизация);

Результат = Запрос.Выполнить();
Результат = Результат.Выбрать();
Если Результат.Следующий() Тогда
Возврат Результат.СуммаОстатокДт;
Иначе
Возврат 0;
КонецЕсли;
КонецФункции

// СКК - Сальдо Конечное Кредитовое
Функция СКК(Счет, ДатаО = Неопределено)
Если ДатаО = Неопределено Тогда ДатаО = КонецДня(КонПериода) КонецЕсли;
СчетПЛ = ПланыСчетов.Хозрасчетный.НайтиПоКоду(Счет);
Если СчетПЛ = ПланыСчетов.Хозрасчетный.ПустаяСсылка() Тогда
Возврат "Нет счета!";
КонецЕсли;
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ХозрасчетныйОстатки.СуммаОстатокДт,
| ХозрасчетныйОстатки.СуммаОстатокКт
|ИЗ
| РегистрБухгалтерии.Хозрасчетный.Остатки(&DatO, Счет В ИЕРАРХИИ (&Scet), , Организация = &Organ) КАК ХозрасчетныйОстатки";
Запрос.УстановитьПараметр("DatO", Новый Граница(ДатаО, ВидГраницы.Включая));
Запрос.УстановитьПараметр("Scet", СчетПЛ);
Запрос.УстановитьПараметр("Organ", знОрганизация);

Результат = Запрос.Выполнить();
Результат = Результат.Выбрать();
Если Результат.Следующий() Тогда
Возврат Результат.СуммаОстатокКт;
Иначе
Возврат 0;
КонецЕсли;

КонецФункции


Пример использования:
Код 1C v 8.х
 ТекЗнач = СКД("04.01")-СКК("05")+СКД("08.05"); 
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 7506
 +1 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
COM-соединение не обнаружило свободной лицензии / ключ защиты 0
Иногда при подключении к 1С возникает ошибка: COM-соединение не обнаружило свободной лицензии! COM-соединение не обнаружило ключ защиты программы! https://helpf.pro/uploads/img/_1-UsuyAg6E2P.jpg В таких случаях, иногда, может помочь...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.