helpf.pro
Регистрация
 -1 
Распечатать

Программная проверка счета на групповой

Как известно делать проводки по счетам-группам нельзя. Однако жизнь течет и после введения бухгалтером очередного нового счета какой либо старый, который ранее не являлся счетом-группы, теперь становится групповым. И соответственно все проводки на этот счет становятся ошибочными. Для предупреждения подобной ситуации целесообразно перед записью данных по счетам имеет смысл всегда проверять счета на предмет группы. Один из возможных вариантов такой проверки привожу ниже:

Код 1C v 8.3
 

Процедура ПриЗаписи(Отказ, РежимЗаписи)
      
    Запрос = Новый Запрос;
    Запрос.Текст = 
        "ВЫБРАТЬ
        | Хозрасчетный.Код КАК Код,
        |   Хозрасчетный.Родитель.Код КАК РодительКод
        |ИЗ
        |ПланСчетов.Хозрасчетный КАК Хозрасчетный
        |ГДЕ
    |Хозрасчетный.Родитель В (&СчетДт,СчетКт)";
    
    СчетДт = ЭтотОбъект[0].СчетДт;
    СчетКт = ЭтотОбъект[0].СчетКт;
    
    Запрос.УстановитьПараметр("СчетДт", СчетДт);
    Запрос.УстановитьПараметр("СчетКт", СчетКт);
    
    РезультатЗапроса = Запрос.Выполнить();
    
    Если НЕ РезультатЗапроса.Пустой() Тогда
        
        ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
        
        Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
            Если СтрНайти(ВыборкаДетальныеЗаписи.Код, ".") Тогда
                Отказ = Истина; 
                Сообщить("Некорретный номер счета - " + ВыборкаДетальныеЗаписи.РодительКод);   
            КонецЕсли;
        КонецЦикла;
    КонецЕсли;
КонецПроцедуры


Разместил:   Версии: | 8.2 УП | 8.3 |  Дата:   Прочитано: 281
 -1 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 44
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
аванс, нет кнопки расчитать 1
подскажите пожалуйста, стоит 1с 8.3 бухгалтерский учет для Украины2.0 на одной платформе 2 предприятия. В одном предприятии при офрмлении документа "ведомости выплаты через банк" Аванс (без предварительного расчета) есть две кнопки "заполнить" и "р
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура РасчетШириныКолонок(Табличный
В ЗУП не исчисляются суммы районного коэффициента и северной надбавки? 1
В Зарплата и управление персоналом 8 почему при расчете среднего заработка для начисления очередного отпуска не исчисляются суммы районного коэффициента и северной надбавки? При исчислении среднего заработка во всех случаях, в том числе для оплаты о
В Книгу продаж по постановлению 1137 не попадают с/ф без НДС 3
Вопрос : Обновили бухгалтерию, появилась новая книга продаж, но счета-факутры без НДС в нее не попадают, а в старой книге продаж все отображается хорошо! Ответ : Без НДС заполняется только в двух случаях: 1. Дата окончания периода формирования м
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.