helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Получение текста web-страницы используя HTTPСоединение

Код 1C v 8.х
 //На прямую
Сервер = "w1c.ru";
Соединение = Новый HTTPСоединение(Сервер);
Заголовки = Новый Соответствие;
Заголовки.Вставить("host", Сервер);
Запрос = Новый HTTPЗапрос("/work.html", Заголовки);
Ответ =Соединение.Получить(Запрос);
Если Ответ.КодСостояния = 200 Тогда // Данные получены, обрабатываем их
ТекстСтраницы= Ответ.ПолучитьТелоКакСтроку();
//Выведем тест полученной страницы
Сообщить(ТекстСтраницы);
КонецЕсли;


Код 1C v 8.х
 	// ЧЕРЕЗ ФАЙЛ
Сервер = "w1c.ru";
НТТР = Новый HTTPСоединение(Сервер);
врФайл = КаталогВременныхФайлов()+"pr_"+Формат(ТекущаяДата(), "ДФ=ddMMyyhhmmss")+".txt";
Ответ = НТТР.Получить("/work.html", врФайл);
Если Ответ.КодСостояния = 200 Тогда // Данные получены, обрабатываем их
//Выведем тест полученной страницы
ВходящийФайл = Новый Файл(врФайл);
//Сообщить(ВходящийФайл.Размер());
Текст = Новый ТекстовыйДокумент;
Текст.Прочитать(врФайл,КодировкаТекста.UTF8);
Для н=1 По Текст.КоличествоСтрок()Цикл
стр=Текст.ПолучитьСтроку(н);
//Выводим текст страницы построчно
Сообщить(стр);
КонецЦикла;
КонецЕсли;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9707
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Автоматическая архивация баз 1С с использованием Cobian Backup и VBS скриптов 6
Клиент попросил настроить автоматическую архивацию баз 1С раз в три дня и выгрузку архивов на Dropbox и на FTP Сервер. Кроме 1С нужно архивировать папку с рабочими документами. Хочет - так хочет, делаем: Первым делом...
Внутренняя ошибка компоненты DBENG8 0
Ошибка СУБД: Внутренняя ошибка компоненты dbeng8 по причине: Внутренняя ошибка компоненты dbeng8 Решение: 1: Тестирование исправление базы 2: Проверка базы используя chdbfl.exe 3: Обновить версию Платформы 4: Обновить dbeng8.dll...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.