helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Функция проверки необходимости перерасчета и Перерасчет записей

Код 1C v 8.х
 // Проверяет необходимость выполнения перерасчета документа. 
Функция НеобходимостьПерерасчета(Регистратор) Экспорт

Запрос = Новый Запрос( "ВЫБРАТЬ ПЕРВЫЕ 1
| Перерасчет.ФизЛицо
|ИЗ
| (ВЫБРАТЬ ПЕРВЫЕ 1
| Перерасчет.ФизЛицо КАК ФизЛицо
| ИЗ
| РегистрРасчета.ОсновныеНачисленияРегл.ПерерасчетОсновныхНачислений
| КАК Перерасчет
| ГДЕ
| Перерасчет.ОбъектПерерасчета = &Регистратор

|

| ОБЪЕДИНИТЬ ВСЕ
|
| ВЫБРАТЬ ПЕРВЫЕ 1
| Перерасчет.ФизЛицо
| ИЗ
|РегистрРасчета.ДополнительныеНачисленияРегл.ПерерасчетДополнительныхНачислений
| КАК Перерасчет
| ГДЕ
| Перерасчет.ОбъектПерерасчета = &Регистратор) КАК Перерасчет");

Запрос.УстановитьПараметр("Регистратор", Регистратор); Если Запрос.Выполнить().Пустой() Тогда
Возврат Ложь;

Иначе

Возврат Истина;
КонецЕсли;

КонецФункции // НеобходимостьПерерасчета

Данная функция возвращает значение Истина, если хотя бы в одной из таблиц перерасчета есть хотя бы одна запись по данному документу. Если таких записей нет, то функция вернет значение Ложь, и перерассчитывать записи этого документа не нужно.

Собственно перерасчет записей, как и их расчет, рекомендуется выполнять в процедуре общего модуля по тем же причинам, что и расчет. Процедура перерасчета отличается от процедуры расчета только тем, что в расчете участвуют не все записи документа, а только удовлетворяющие усло- виям проводимого перерасчета. Например, только записи по конкретным сотрудникам и конкретным видам расчета.

Наконец, после того как нужные записи перерассчитаны, необхо- димо средствами встроенного языка удалить соответствующие записи из таблицы перерасчета, так как перерасчет больше не требуется.
Процедуру перерасчета записей документа рекомендуется помещать в модуле этого документа как экспортную процедуру. В этом случае она может быть вызвана из других модулей, в том числе из обработки перерасчета, описанной в предыдущем разделе. В качестве параметров в процедуру должна передаваться информация о том, какие именно записи документа необходимо перерассчитать. Ниже приведен пример такой процедуры, где в качестве параметра используется список сотрудников, по которым необходимо выполнить перерасчет.

Процедура перерасчета записей документа
Код 1C v 8.х
 Процедура Перерассчитать(Физлица = Неопределено) Экспорт

// Перерасчет выполняется в транзакции. НачатьТранзакцию();
Если Не Расчеты.НеобходимостьПерерасчета(Ссылка) Тогда
Возврат; КонецЕсли;

// Считать движения документа по регистрам расчета. Движения.ОсновныеНачисленияРегл.Прочитать(); Движения.ДополнительныеНачисленияРегл.Прочитать();

// Перерасчет и перезапись движений по регистрам расчета.
Расчеты. ПерерассчитатьЗаписиРегистраРасчета("ОсновныеНачисленияРегл", Движения.ОсновныеНачисленияРегл, ОсновныеНачисления, Физлица);
Движения.ОсновныеНачисленияРегл.Записать(Истина, Истина);

Расчеты.ПерерассчитатьЗаписиРегистраРасчета("ДополнительныеНачисленияРегл", Движения.ДополнительныеНачисленияРегл, ДополнительныеНачисления, Физлица);
Движения.ДополнительныеНачисленияРегл.Записать(Истина, Истина);

// Записать измененные данные табличных частей документа. Записать();

// Удалить записи перерасчета, по которым выполнен перерасчет. Для Н = 1 По 2 Цикл
Если Н = 1 Тогда
НаборЗаписей = РегистрыРасчета.ОсновныеНачисленияРегл.
Перерасчеты.ПерерасчетОсновныхНачислений. СоздатьНаборЗаписей();
НаборЗаписей.Записать(); КонецЦикла;

// Перерасчет выполняется в транзакции. ЗафиксироватьТранзакцию();

КонецПроцедуры


Процедуры общего модуля, выполняющие непосредственный перерасчет записей, по алгоритму схожи с процедурами расчета. Основное отличие состоит в том, что в процедурах перерасчета происходит расчет только тех записей, которые удовлетворяют заданным условиям. В данном случае это записи по заданному списку сотрудников. Также при перерасчете не нужно производить предварительную запись набора с формированием фактического периода действия, так как набор уже записан в регистр (перерассчитываемый документ всегда проведен). Ниже приведен пример процедур ПерерассчитатьЗаписиРегистраРасчета() и ПерерассчитатьНаборЗаписей(). Эти процедуры используют вызов тех же самых процедур и функций, которые используются при расчете.

Процедуры перерасчета записей
Код 1C v 8.х
 Процедура ПерерассчитатьНаборЗаписей(НаборЗаписей, Приоритет, ТабличнаяЧасть = Неопределено, ФизЛица = Неопределено)

Для каждого Запись из НаборЗаписей Цикл
Если Запись.ВидРасчета.Приоритет = Приоритет Тогда
Если НЕ ФизЛица.НайтиПоЗначению(Запись.Физлицо) = Неопределено Тогда

// Получить данные для расчета записи.
ДанныеДляРасчета = ПолучитьДанныеДляРасчета(Запись);

Иначе

НаборЗаписей = РегистрыРасчета.ДополнительныеНачисленияРегл.
Перерасчеты.ПерерасчетДополнительныхНачислений. СоздатьНаборЗаписей();

// Вызвать процедуру расчета записи. РассчитатьЗапись(Запись, ДанныеДляРасчета);

КонецЕсли;
НаборЗаписей.Отбор.ОбъектПерерасчета.Значение = Ссылка; Если Физлица <> НеОпределено Тогда
НаборЗаписей.Прочитать(); СтрокиКУдалению = Новый Массив;

Для Каждого СтрокаПерерасчета из НаборЗаписей Цикл
Если Физлица.НайтиПоЗначению( СтрокаПерерасчета.Физлицо) <> НеОпределено Тогда СтрокиКУдалению.Добавить(СтрокаПерерасчета);
КонецЕсли; КонецЦикла;

Для Каждого Строка Из СтрокиКУдалению Цикл
НаборЗаписей.Удалить(Строка); КонецЦикла;
КонецЕсли;
// Вернуть результат расчета в табличную часть документа. Если Не ТабличнаяЧасть = Неопределено Тогда
СтрокаТабличнойЧасти = ТабличнаяЧасть.Получить(Запись.НомерСтроки-1);
СтрокаТабличнойЧасти.Результат = Запись.Результат; КонецЕсли;
КонецЕсли; КонецЕсли;
КонецЦикла;

КонецПроцедуры

Процедура ПерерассчитатьЗаписиРегистраРасчета(ИмяРегистра,
НаборЗаписей, ТабличнаяЧасть = Неопределено, Физлица = Неопределено) Экспорт

Регистратор = НаборЗаписей.Отбор.Регистратор.Значение;

// Запрос по приоритетам видов расчета
// только записей заданных сотрудников.

Запрос = Новый Запрос; Запрос.Текст = "
|ВЫБРАТЬ РАЗЛИЧНЫЕ
| " + ИмяРегистра + ".ВидРасчета.Приоритет КАК Приоритет
|ИЗ
| РегистрРасчета." + ИмяРегистра + " КАК " + ИмяРегистра + "
|ГДЕ
| ФизЛицо В (&СписокФизлиц) И Регистратор = &Регистратор
|УПОРЯДОЧИТЬ ПО
| Приоритет
|ИТОГИ ПО
| " + ИмяРегистра + ".ВидРасчета.Приоритет";

Запрос.УстановитьПараметр("СписокФизлиц", Физлица); Запрос.УстановитьПараметр("Регистратор", Регистратор);

ВыборкаПриоритетов = Запрос.Выполнить().
Выбрать(ОбходРезультатаЗапроса.ПоГруппировкам);

// Для каждого значения приоритета выполняется расчет записей. Пока ВыборкаПриоритетов.Следующий() Цикл
ПерерассчитатьНаборЗаписей(НаборЗаписей, ВыборкаПриоритетов.Приоритет, ТабличнаяЧасть, Физлица);

// Записать набор в регистр для расчета записей следующего
// приоритета, фактический период действия не пересчитывается. НаборЗаписей.Записать(Истина, Истина);
КонецЦикла;

КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 5842
 0 
Распечатать
Возможно, вас также заинтересует
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
Блокировка записей, невозможно изменить или удалить из регистра. Конфликт блокировок MS SQL + 1C 1
При попытке удалить запись из регистра сведений - получаю ошибку: она заблокирована, ошибка блокировок и т.д. Отключил всех пользователей, перезапустил сервер, пробую удалить - опять ошибка блокировки :( Путем тестов...
Временные таблицы 0
Не помню уже с какого релиза в запросах стало можно использовать временные таблицы. Для этого используется объект «Менеджер временных таблиц». Фактически менеджер временных таблиц описывает пространство имен...
Добавление в набор сторно-записей 0
Если в рассчитываемом регистре установлено свойство Период действия, в сформированном наборе могут присутствовать записи, у которых период действия принадлежит более раннему периоду, чем период регистрации. В этом...
Документ "Корректировка записей регистров" - Как программно создать и заполнить? 2
Документ «Корректировка записей регистров» в типовых конфигурациях 1С предназначен для ручной корректировки записей регистров накопления, зависимых регистров сведений и регистров бухгалтерии. Типичные ситуации, в...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.