helpf.pro
Регистрация
 +4 
Распечатать

1С 8.2 УП : Как программно прочитать Журнал Регистрации?

Код 1C v 8.х
  ИмяФайла=ПолучитьИмяВременногоФайла("XML");
Результат.Очистить();
Фильтр=Новый Структура;
Фильтр.Вставить("ДатаНачала", НачалоПериода);
Фильтр.Вставить("ДатаОкончания", ОкончаниеПериода);
Фильтр.Вставить("Событие", "_$Data$_.Post");
Состояние("Выгрузка журнала...");
ВыгрузитьЖурналРегистрации(ИмяФайла, Фильтр, "Дата, Метаданные, Данные, ПредставлениеДанных, ИмяПользователя");
Состояние("Обработка журнала...");
ЧтениеXML=Новый ЧтениеXML;
ЧтениеXML.ОткрытьФайл(ИмяФайла);
ПостроительDOM=Новый ПостроительDOM;
ДокументDOM=ПостроительDOM.Прочитать(ЧтениеXML);
Event=ДокументDOM.ПолучитьЭлементыПоИмени("v8e:Event");
Для й=0 По Event.Количество()-1 Цикл
ДочерниеУзлы=Event[й].ДочерниеУзлы;
Для Каждого Узел Из ДочерниеУзлы Цикл
Если Узел.ИмяУзла="v8e:Date" Тогда
ДатаСобытия=СтрЗаменить(Узел.ТекстовоеСодержимое, "T", "");
ДатаСобытия=СтрЗаменить(ДатаСобытия, ":", "");
ДатаСобытия=Дата(СтрЗаменить(ДатаСобытия, "-", ""));
ИначеЕсли Узел.ИмяУзла="v8e:MetadataName" Тогда
МетаданныеДокумента=СтрЗаменить(Узел.ТекстовоеСодержимое, "Document.", "");
ИначеЕсли Узел.ИмяУзла="v8e:Data" Тогда
УИД=Узел.ТекстовоеСодержимое;
ИначеЕсли Узел.ИмяУзла="v8e:DataPresentation" Тогда
ПредставлениеДанных=Узел.ТекстовоеСодержимое;
ИначеЕсли Узел.ИмяУзла="v8e:UserName" Тогда
Пользователь=Узел.ТекстовоеСодержимое;
КонецЕсли;
КонецЦикла;
Ссылка=Документы[МетаданныеДокумента].ПолучитьСсылку(Новый УникальныйИдентификатор(УИД));
ДатаОбъекта=Ссылка.Дата;

НоваяСтрока=Результат.Добавить();
НоваяСтрока.ДатаСобытия=ДатаСобытия;
НоваяСтрока.ДатаОбъекта=ДатаОбъекта;
НоваяСтрока.ПредставлениеДанных=ПредставлениеДанных;
НоваяСтрока.Пользователь=Пользователь;
НоваяСтрока.РазностьДат=Окр((ДатаСобытия-ДатаОбъекта)/86400);
НоваяСтрока.Ссылка=Ссылка;
КонецЦикла;
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9523
 +4 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
Ввод договоров ГПХ в ЗУП (счет 76) 5
Часто меня спрашивают: Как правильно отразить договор ГПХ в ЗУП? Ниже небольшая, последовательная инструкция: Прием на работу Сведения о физическом лице, выполняющем работы по договору подряда, должны быть внесены...
Выгрузка из 1С на SFTP 0
Думаю, что все знают, как работает 1с с FTP сервером, но вот как работать с sFTP или FTPs сервером? Первое что Вам нужно сделать - это установить бесплатную программу WinSCP, скачать ее Вы сможете здесь, также там есть вся...
Где список открытых окон (документов, справочников) в такси? 1
В текущей работе пользователь обычно открывает несколько объектов. Это может быть документ, справочник, отчет и т.д. В предыдущем интерфейсе не было проблем быстро найти открытый объект и актуализировать его для...
Где физически находится Журнал регистрации? 2
В файловом варианте информационной базы «1С:Предприятие 8.0» журнал регистрации располагается в каталоге информационной базы, там же, где и файл самой информационной базы. Например, если информационная база хранится в...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.