helpf.pro
Регистрация
 -1 
Распечатать

1С 8.2 УП : Как проверить целое число? Четное число?

Код 1C v 8.х
 Функция ЧетноеЧисло(пЧисло)    
Четное = пЧисло%2=0;
Возврат Четное;
КонецФункции


Код 1C v 8.х
 
Функция ровноеЧисло(пЧисло)
Четное = пЧисло%2=1;
Возврат Четное;
КонецФункции

//или

Фунция ДровноеЧисло (Чис)
Возврат Чис = Цел(Чис);
КонецФункции


Код 1C v 7.x
 Функция ДробноеЧисло (Чис)
Возврат ?(Чис = Цел(Чис),1,0);
КонецФункции
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 7620
 -1 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Будут ли работать два клиентских ключа защиты 1С:Предприятия 8 на одном компьютере? 0
Рекомендуем ознакомиться с документацией по 1С:Предприятию 8. " Руководства по установке и запуску" , глава 6, второй абзац: " ... К USB-портам одного компьютера не имеет смысла присоединять несколько аппаратных ключей HASP4...
В отчет не попадают данные за последний день… Как исправить? 0
Пользователь выбрал период формирования отчета с 1июля по 31. Почему при формировании отчета в него не попадают данные за 31 число? На самом деле, это одна из самых распространенных ошибок при разработке отчетов. В 1С 8.х...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.