helpf.pro
Регистрация
 +2 
Распечатать

1С 8.2 УП : Как сделать из распределенной базы обычную?

Для 8.х:
Как отключить узел от распределенной информационной базы?
Поскольку сама конфигурация заблокирована, то этот код надо создавать в обработке, открыв каую-нибудь другую (незаблокированную) конфигурацию, вставить кнопку в конфигураторе. Сохранить её как внешнюю обработку и выполнить, запустив базу в режиме 1С:Предприятие в монопольном режиме (и открыв внешнюю обработку из файла).

При этом, этот код нельзя выполнить в режиме отладчика, т.е./или имея конфигуратор открытым на отключаемой базе, поскольку требуется исключительная блокировка доступа к базе этого кода.

Название параметра не имеет значение, хотя по умолчанию, параметр процедуры для кнопки командной панели
Код 1C v 8.х
 Процедура ОтключитьГлавныйУзелНажатие(Кнопка)   


будет проставляется как "Кнопка", а вставляемой через меню Форма --> Вставить элемент управления... подучается "Элемент"
Код 1C v 8.х
 Процедура ОтключитьГлавныйУзелНажатие(Элемент)   


Готовая обработка для 8.1 - Отключить Восстановить Подчиненный узел от Главного узела Скачивать файлы может только зарегистрированный пользователь!

Привожу тут код внешней обработки отключение - восстановление подключения к УРБД:
Код 1C v 8.х
 Процедура ОтключитьГлавныйУзелНажатие(Элемент)
Если ПланыОбмена.ГлавныйУзел()<> Неопределено Тогда
СохранитьЗначение("ВосстановитьЗначениеГлавногоУзлаВПодчиненном",
ПланыОбмена.ГлавныйУзел());
ПланыОбмена.УстановитьГлавныйУзел(Неопределено);
КонецЕсли;
Предупреждение("Главный узел отключен");
КонецПроцедуры

Процедура ВосстановитьГлавныйУзелНажатие(Элемент)
Если ПланыОбмена.ГлавныйУзел()= Неопределено Тогда
ПланыОбмена.УстановитьГлавныйУзел(
ВосстановитьЗначение(
"ВосстановитьЗначениеГлавногоУзлаВПодчиненном"));
КонецЕсли;
Предупреждение("Главный узел восстановлен");
КонецПроцедуры


Для 7.7:
При преобразовании информационной базы в режим использования компоненты УРБД (Управление Распределенными Информационными Базами), в ИБ вносятся некоторые изменения, не позволяющие использовать базу в обычном режиме. А именно: добавляются три таблицы, отвечающие за процесс синхронизации, и вносятся изменения в таблицу 1ssystem.dbf Не забудьте сделать резервную копию перед тем, как: Удалить файлы 1sdbset.dbf, 1sdbset.cdx, 1sdwnlds.dbf, 1sdwnlds.cdx, 1supdts.dbf, 1supdts.cdx Удалить единственную запись из файла 1ssystem.dbf Зайти в режим конфигуратора, открыть, например, свойства конфигурации, добавить какой-нибудь символ в комментарий, а потом его удалить. После этого сохранить конфигурацию.
Разместил:   Версии: | 7.x | 8.x | 8.2 УП |  Дата:   Прочитано: 27826
 +2 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Ввод по строке - поиск по первым символам или в любом месте наименования 0
При разработке конфигурации, для упрощении ввода документов потребовалось настроить ввод номенклатуры по совпадению любой части наименования! В 1С 8.3 по умолчанию настройки справочника номенклатуры такие: При...
Внутренняя ошибка компоненты DBENG8 0
Ошибка СУБД: Внутренняя ошибка компоненты dbeng8 по причине: Внутренняя ошибка компоненты dbeng8 Решение: 1: Тестирование исправление базы 2: Проверка базы используя chdbfl.exe 3: Обновить версию Платформы 4: Обновить dbeng8.dll...
Выборка данных из DBF файлов запросом 0
RS= Новый COMОбъект(" ADODB.Recordset" ); SSource = " S_elect * FROM nomen.dbf WHERE cost 100" ; SConnect = " Provider=MSDASQL.1;Persist Security Info=False;Data Source=nomen.dbf;Initial Catalog=D:" ; RS.Open(SSource,SConnect); Пока RS.EOF() =
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.