helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как получить количество рабочих дней в месяце по календарю?

Для одного проекта потребовалось получить количество рабочих дней в месяце по календарю, без учета праздников.

В результате получилась простая функция:

Код 1C v 8.3
 Функция ПолучитьКолВоРабочихДнейПоКалендарю(ДатаМесяца)
Рабочие=0;
Кон=НачалоМесяца(ДатаМесяца); КонМес = КонецМесяца(ДатаМесяца);
Пока Кон<=КонМес Цикл 
Если (ДеньНедели(Кон)=6) или (ДеньНедели(Кон)=7)Тогда
//выходные дни не считаем
Иначе
Рабочие=Рабочие+1;      
КонецЕсли;    
Кон=Кон+86400;
КонецЦикла;
Возврат Рабочие;            
КонецФункции

А получить количество Выходных дней в месяце можно так:

Код 1C v 8.3
 Функция ПолучитьКолВоРабочихДнейПоКалендарю(ДатаМесяца)
Вых=0;
Кон=НачалоМесяца(ДатаМесяца); КонМес = КонецМесяца(ДатаМесяца);
Пока Кон<=КонМес Цикл 
Если (ДеньНедели(Кон)=6) или (ДеньНедели(Кон)=7)Тогда
Вых=Вых+1;      
КонецЕсли;    
Кон=Кон+86400;
КонецЦикла;
Возврат Вых;            
КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 3503
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.