helpf.pro
Регистрация
 +1 
Распечатать

1С 8.2 УП : запрос ФИО руководителя полностью, сделал на основе оригинальной функции

Код 1C v 8.2 УП
 Функция ОтветственныеЛицаОрганизации(Организация, ДатаСреза, Исполнитель = Неопределено) Экспорт

    Результат = Новый Структура("Руководитель, РуководительДолжность, ГлавныйБухгалтер, Кассир");
    
    Если Организация <> Неопределено тогда

          ЗапросПоЛицам = Новый Запрос();
        ЗапросПоЛицам.УстановитьПараметр("Организация", Организация);
        ЗапросПоЛицам.УстановитьПараметр("ДатаСреза",   ДатаСреза);
        ЗапросПоЛицам.Текст = "
        |ВЫБРАТЬ РАЗРЕШЕННЫЕ
        |    ОтветственныеЛицаОрганизацииСрезПоследних.ОтветственноеЛицо,
        |    ОтветственныеЛицаОрганизацииСрезПоследних.Должность.Наименование КАК Должность,
        |    ВЫБОР КОГДА (ФИОФизЛицСрезПоследних.ФизЛицо) ЕСТЬ NULL  ТОГДА ОтветственныеЛицаОрганизацииСрезПоследних.ФизическоеЛицо.Наименование ИНАЧЕ ФИОФизЛицСрезПоследних.Фамилия + ВЫБОР КОГДА (ФИОФизЛицСрезПоследних.Имя) <> """" ТОГДА "" "" + (ФИОФизЛицСрезПоследних.Имя) ИНАЧЕ """" КОНЕЦ + ВЫБОР КОГДА (ФИОФизЛицСрезПоследних.Отчество) <> """" ТОГДА "" "" + (ФИОФизЛицСрезПоследних.Отчество) ИНАЧЕ """" КОНЕЦ КОНЕЦ КАК ФИОПолное
        |ИЗ
        |    РегистрСведений.ОтветственныеЛицаОрганизации.СрезПоследних(&ДатаСреза, СтруктурнаяЕдиница =Организация) КАК ОтветственныеЛицаОрганизацииСрезПоследних
        |        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ФИОФизЛиц.СрезПоследних(&ДатаСреза, ФизЛицо ССЫЛКА Справочник.ФизическиеЛица) КАК ФИОФизЛицСрезПоследних
        |        ПО ОтветственныеЛицаОрганизацииСрезПоследних.ФизическоеЛицо = ФИОФизЛицСрезПоследних.ФизЛицо";
                
        Выборка = ЗапросПоЛицам.Выполнить().Выбрать();
                
        Пока Выборка.Следующий() Цикл

              Если Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизации.Руководитель Тогда
                Результат.Руководитель            = Выборка.ФИОПолное;
                Результат.РуководительДолжность   = Выборка.Должность;

              ИначеЕсли Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизации.ГлавныйБухгалтер Тогда
                Результат.ГлавныйБухгалтер        = Выборка.ФИОПолное;

              ИначеЕсли Выборка.ОтветственноеЛицо = Перечисления.ОтветственныеЛицаОрганизации.Кассир Тогда
                Результат.Кассир                  = Выборка.ФИОПолное;

              КонецЕсли;

          КонецЦикла;
    КонецЕсли;

    Возврат Результат;

КонецФункции // ОтветственныеЛицаОрганизации()
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 2022
 +1 
Распечатать
Возможно, вас также заинтересует
ZIP-архив Создание 0
Для того чтобы записать файлы в ZIP-архив необходимо выполнить несколько простых действий: * Создать архив с необходимыми параметрами, в который будут помещаться файлы. * Поместить в архив необходимые файлы. * Записать...
Внутреннее устройство PostgreSQL, в помощь администраторам 1С 0
Понимание архитектуры используемой СУБД очень важно для правильной эксплуатации, но местами переоценено: администратору, DevOps-специалисту или разработчику прикладных систем вовсе необязательно знать подробности...
Географическая схема - что это? 0
Географическая схема позволяет наглядно представить итоговые данные в разрезе их географического положения. Это позволяет создавать отчеты иллюстрирующие, например, объемы продаж тех или иных товаров в различных...
Как создать Фиксированный массив? 2
ФиксированныйМассив , элементами которого могут быть значения перечисленных типов, включая ФиксированныйМассив. ФиксированныйМассив не допускает никаких изменений своего содержимого и может быть сконструирован...
Конструктор запросов схемы компоновки данных 0
Конструктор запроса состоит из следующих закладок: https://helpf.pro/uploads/img/sukpd014.png 1. «Таблицы и поля» - на закладке три иерархических списка: a. «База данных» - перечислены все доступные объекта, к которым можно сделать...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.