helpf.pro
Регистрация
 +2 
Распечатать

1С 8.2 УП : Как удалить строку или очистить дерево значений

Помните, что при при удалении/очистке строки, все подчиненные строки удаляются.

Очистить дерево значений: Дерево.Строки.Очистить();

Код 1C v 8.2 УП
 &НаСервере
Процедура ОчиститьНаСервере()
   тДерево = РеквизитФормыВЗначение("Дерево");
 
   тДерево.Строки.Очистить();
 
   ЗначениеВРеквизитФормы(тДерево, "Дерево");
КонецПроцедуры

Точно также можно очистить от подчиненных элементов другую другую строку.

Удалить строку дерева значений не сложнее & нужно только знать ее индекс:

Код 1C v 8.2 УП
 &НаКлиенте
Процедура Удалить(Команда)
   УдалитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура УдалитьНаСервере()
   тДерево = РеквизитФормыВЗначение("Дерево");
 
   тДерево.Строки.Удалить(0);
 
   ЗначениеВРеквизитФормы(тДерево, "Дерево");
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП | 8.3 |  Дата:   Прочитано: 44068
 +2 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 8
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код заполнения ТЧ НаСервере П
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 50
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
1C и Google Maps 21
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во время решения задачи было реш
COM-подключение к базе 7.7 из 8.2 1С 6
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе=" D:ВашаБаза1с77" ; Пользователь=
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 1
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже веб-узла в э
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.