helpf.pro
Регистрация
 -5 
Распечатать

1С 8.2 УП : Запрос с ответом

простое решения как получить значения с запросом. 

Код 1C v 8.х
 
Функция ШтрихКодВыбрать (Наименование);
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
               | Штрихкоды.Штрихкод
               |ИЗ
               | РегистрСведений.Штрихкоды КАК Штрихкоды
               |ГДЕ
               | Штрихкоды.Владелец.Наименование =Наименование";
   
Запрос.УстановитьПараметр("Наименование",Наименование);
Результат = Запрос.Выполнить().Выбрать();


Если Результат.Следующий() Тогда
ШТ =Результат.Штрихкод;
КонецЕсли;
Возврат ШТ;
КонецФункции


Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 2987
 -5 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 6
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код заполнения ТЧ НаСервере П
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 31
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно использовать, когда требуется получ
1C и Google Maps 17
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во время решения задачи было реш
COM-подключение к базе 7.7 из 8.2 1С 6
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе=" D:ВашаБаза1с77" ; Пользователь=
Cклонения по падежам 5
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) Результат = " " ;
Посмотреть все результаты поиска похожих
Комментарии
alecs1970
06.08.2019 12:41Комментарий: 1
alecs1970

А если штрихкод не найден, то при возврате возникнет ошибка.

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.