helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Реквизит ~ Cохранение значений реквизитов формы в файл

Код 1C v 8.х
 //Cохранение значений реквизитов формы в файл - таблицу значений тоже сохраняет.
Код следующий:
Процедура СохранитьЗначенияФормы()
СтруктураЭлементов = Новый Структура;
Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
Если ЗначениеЗаполнено(ЭлементФормы.Данные) Тогда
ЗнВСтр = ЗначениеВСтрокуВнутр(ЭлементФормы.Значение);
СтруктураЭлементов.Вставить(ЭлементФормы.Имя, ЗнВСтр);
КонецЕсли;
КонецЦикла;
ЗначениеВФайл("C:\temp\rekv.ini", СтруктураЭлементов);
КонецПроцедуры

Процедура ВосстановитьЗначенияФормы()
СтруктураЭлементов = Новый Структура;
СтруктураЭлементов = ЗначениеИзФайла("C:\temp\rekv.ini");
Для Каждого ЭлементФормы Из ЭлементыФормы Цикл
Попытка
ЭлементФормы.Значение = ЗначениеИзСтрокиВнутр(СтруктураЭлементов[ЭлементФормы.Имя])
Исключение
КонецПопытки;
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 9519
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.