helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Реквизит ~ Проверка на заполненность реквизитов формы, с признаком АвтоОтметкаНезаполненного

Код 1C v 8.х
  //Проверка на заполненность реквизитов формы, для которых установлен признак АвтоОтметкаНезаполненного
Функция ПроверкаАвтоОтметкаНезаполненного(ЭлементыФормы) Экспорт

Результат = Ложь;

Для каждого Элемент Из ЭлементыФормы Цикл
Если ТипЗнч(Элемент) = Тип("ПолеВвода") Тогда
Если Элемент.АвтоОтметкаНезаполненного И ЗначениеНеЗаполнено(Элемент.Значение) Тогда
Сообщить("Необходимо заполнить обязательное поле ввода: " + Элемент.Подсказка, СтатусСообщения.Внимание);
Результат = Истина;
КонецЕсли;

ИначеЕсли ТипЗнч(Элемент) = Тип("ТабличноеПоле") Тогда

СоставПоля = Элемент.Значение;
Колонки = Элемент.Колонки;
Попытка // для ДокументСписок вызовет исключение

Для каждого Строка Из СоставПоля Цикл
Для каждого Колонка Из Колонки Цикл
Если ТипЗнч(Колонка.ЭлементУправления) = Тип("ПолеВвода") Тогда
Если Колонка.АвтоОтметкаНезаполненного И ЗначениеНеЗаполнено(Строка[Колонка.Данные]) Тогда
Сообщить("Необходимо заполнить обязательное поле ввода табличной части: " + Колонка.ТекстШапки, СтатусСообщения.Внимание);
Результат = Истина;
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЦикла;
Исключение
КонецПопытки;

КонецЕсли;

КонецЦикла;

Возврат Результат;
КонецФункции
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 11476
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
V82.COMConnector.1: Не найдена лицензия COM-соединением 1
При подключении из одной базы к другой через COM внезапно стала появляться следующая ошибка: «V82.COMConnector.1: Не найдена лицензия COM-соединением», хотя никаких изменений на серверах не делалось. Релиз платформы был 8.2.13....
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.