helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Быстрый отбор в справочнике по первой букве

В статье описан способ быстрой организации отбора в списке справочника по первой букве наименования. Механизм легко дотачивается под собственные нужды.
title
Код 1C v 8.2 УП
 // ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ  

&НаКлиенте
Процедура УстановитьПометку(Команда)

Для Каждого Кнопка Из Элементы.ПанельСБуквами.ПодчиненныеЭлементы Цикл
Кнопка.Пометка = (Команда.Имя = Кнопка.Имя);
КонецЦикла;

КонецПроцедуры // УстановитьПометку()

&НаСервере
Процедура ПодготовитьДинамическийСписок()

Список.ПроизвольныйЗапрос = Истина;
ТекстЗапроса =
"ВЫБРАТЬ *
|ИЗ
| %ИмяТаблицы% КАК Т
|{ГДЕ
| (ПОДСТРОКА(Т.Наименование, 1, 1) В (&СписокБукв))}";
ТекстЗапроса = СтрЗаменить(ТекстЗапроса, "%ИмяТаблицы%", Список.ОсновнаяТаблица);
Список.ТекстЗапроса = ТекстЗапроса;

КонецПроцедуры // ПодготовитьДинамическийСписок()

&НаСервере
Процедура СоздатьПанельСБуквами()

ПанельСБуквами = Элементы.Вставить("ПанельСБуквами", Тип("ГруппаФормы"), ЭтаФорма, Элементы.Список);
ПанельСБуквами.Вид = ВидГруппыФормы.КоманднаяПанель;

// кнопка "Все"
КомандаФормы = Команды.Добавить("Все");
КомандаФормы.Действие = "УдалитьФильтрПоПервойБукве";

КнопкаФормы = Элементы.Добавить("Все", Тип("КнопкаФормы"), ПанельСБуквами);
КнопкаФормы.ИмяКоманды = "Все";
КнопкаФормы.Пометка = Истина;

// кнопки А...Я
Для Сч = КодСимвола("А") По КодСимвола("Я") Цикл

ИмяКоманды = Символ(Сч);
Если Найти("Ё,Й,Ъ,Ь", ИмяКоманды) > 0 Тогда
Продолжить;
КонецЕсли;

КомандаФормы = Команды.Добавить(ИмяКоманды);
КомандаФормы.Действие = "УстановитьФильтрПоПервойБукве";

КнопкаФормы = Элементы.Добавить(ИмяКоманды, Тип("КнопкаФормы"), ПанельСБуквами);
КнопкаФормы.ИмяКоманды = ИмяКоманды;

КонецЦикла;

КонецПроцедуры // СоздатьПанельСКнопками()

////////////////////////////////////////////////////////////////////////////////
// КОМАНДЫ МОДУЛЯ

&НаКлиенте
Процедура УстановитьФильтрПоПервойБукве(Команда)

Буква = Команда.Имя;

СписокБукв = Новый Массив;
СписокБукв.Добавить(Буква);
СписокБукв.Добавить(НРег(Буква));

Если Буква = "Е" Тогда
СписокБукв.Добавить("Ё");
СписокБукв.Добавить("ё");
КонецЕсли;

Если Буква = "И" Тогда
СписокБукв.Добавить("Й");
СписокБукв.Добавить("й");
КонецЕсли;

Список.Параметры.УстановитьЗначениеПараметра("СписокБукв", СписокБукв);

УстановитьПометку(Команда);

КонецПроцедуры

&НаКлиенте
Процедура УдалитьФильтрПоПервойБукве(Команда)

ПараметрКомпоновкиДанных = Новый ПараметрКомпоновкиДанных("СписокБукв");
ЗначениеПараметраКомпоновкиДанных = Список.Параметры.НайтиЗначениеПараметра(ПараметрКомпоновкиДанных);
Если ЗначениеПараметраКомпоновкиДанных = Неопределено Тогда
Возврат;
КонецЕсли;

ЗначениеПараметраКомпоновкиДанных.Использование = Ложь;

УстановитьПометку(Команда);

КонецПроцедуры

////////////////////////////////////////////////////////////////////////////////
// ПРОЦЕДУРЫ - ОБРАБОТЧИКИ СОБЫТИЙ ФОРМЫ

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ПодготовитьДинамическийСписок();
СоздатьПанельСБуквами();

КонецПроцедуры // ПриСозданииНаСервере()

Данный текст необходимо вставить в модуль формы списка справочника.

Процедуру "ПриСозданииНаСервере" вручную назначить обработчиком одноименного события формы.
title

Если данному событию уже назначен обработчик, то необходимо дополнить его строками процедуры "ПриСозданииНаСервере" из листинга.

Реквизита формы "Список" не должен содержать произвольного запроса. Если список формируется произвольным запросом, то в запрос необходимо дописать условие компоновки:
{ГДЕ (ПОДСТРОКА(ИмяТаблицы.Наименование, 1, 1) В (&СписокБукв))}
и удалить процедуру "ПодготовитьДинамическийСписок" и все ее вызовы.

Автор Armando
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 8892
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.