helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Универсальное использование HTML Редактора

Гуляя по просторам интернета, случайно наткнулся на обработку HTML Редактор (Андрей Михайлов aka MAV):

title

Далее, пришла в голову интересная идея, сделать красивыми комментарии в документах ( у нас они очень большие и многострочные, в отдельной закладке), с поддержкой копирования информации из WORD и EXCEL, с сохранением всех цветов и стилей. Подредактировав данную обработку, стали доступны следующие функции:

1. Добавление текста

2. Добавление, просмотр и печать

3. Просмотр и печать

Теперь, более подробно:

Вот так выгляди поле комментариев в нашей базе:
title

1. Нажав на кнопку "Добавить комментарий" срабатывает Процедура ДобавитьКоммент(Элемент)
Код 1C v 8.х
 
Процедура ДобавитьКоммент(Элемент)
форм=обработки.HTML.ПолучитьФорму("Форма");
текст = форм.ОткрытьМодально();
если не Пустаястрока(текст) тогда
комментарий="Добавил: "+глтекущийпользователь+" , Добавлено: "+текущаядата()+текст+комментарий;
ЭлементыФормы.ПолеHTMLДокумента.УстановитьТекст(комментарий);
конецесли;
КонецПроцедуры

2. Процедура вызова "Добавление, просмотр и печать"
Код 1C v 8.х
 
Процедура ВставитьПланГрафик(Кнопка)
форм=обработки.HTML.ПолучитьФорму("ФормаПросмотра");
форм.текст=ПланГрафик;
текст=форм.ОткрытьМодально();
ПланГрафик=текст+ПланГрафик;
КонецПроцедуры

Откроется форма, вида:
title

Нажав на "Добавить запись" и вставив Таблицу из Excel:
title

Нажимаем Добавить и получаем:
title

3. Просмотр и печать
Код 1C v 8.х
 
Процедура ИсторияИзмененийПросмотр(Кнопка)
форм=обработки.HTML.ПолучитьФорму("Просмотр");
форм.текст=ИсторияИзменений;
форм.ОткрытьМодально();
КонецПроцедуры

Откроется форма просмотра реквизита ИсторияИзменений.

Обработка HTML редактор:
Для 8.0
Для 8.1
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 11207
 0 
Распечатать
Возможно, вас также заинтересует
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Временные таблицы, как проверить в отладчике? 0
// Функция для просмотра Временных Таблиц в отладчике Функция ЛукВТ(Запрос, ИмяВнутреннейТаблицы) Экспорт Перем ЗапросТМП, Р; //Получаем таблицу из менеджера временных таблиц запроса ЗапросТМП=Новый Запрос(" ВЫБРАТЬ...
Географическая схема - что это? 0
Географическая схема позволяет наглядно представить итоговые данные в разрезе их географического положения. Это позволяет создавать отчеты иллюстрирующие, например, объемы продаж тех или иных товаров в различных...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.