helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Подписка на событие, Проверка состояния работников при перемещении и увольнении

Необходимо при Увольнении или Перемещении работников проверять - работает ли сотрудник? или он в отпуске, болеет и т.д.?

Для решение этого создадим в разделе Подписки на события, подписку "ПриПроведенииПроверкаСостоянияРаботников"
title

и укажем в её свойствах:
title

А это код обработки из Обработчика:
Код 1C v 8.х
 //Проверка Состояния Сотрудников // для обработчика Подписка на Событие
Процедура ПриПроведенииПроверкаСостоянияРаботниковОбработкаПроведения(Источник, Отказ, РежимПроведения) Экспорт
ОчиститьСообщения();
Если ТипЗнч(Источник.Ссылка) = Тип("ДокументСсылка.УвольнениеИзОрганизаций") Тогда
Для Каждого Сотр из Источник.РаботникиОрганизации Цикл
Сост=РегистрыСведений.СостояниеРаботниковОрганизаций.ПолучитьПоследнее(Сотр.ДатаУвольнения, Новый Структура("Сотрудник",Сотр.Сотрудник));
Если НЕ Сост.Состояние = Перечисления.СостоянияРаботникаОрганизации.Работает Тогда
Если Сост.СостояниеЗавершения = Перечисления.СостоянияРаботникаОрганизации.Работает и Сотр.ДатаУвольнения < Сост.ПериодЗавершения Тогда
Сообщить("Сотрудник "+Строка(Сотр.Сотрудник)+" на "+Формат(Сотр.ДатаУвольнения, "ДЛФ=DD")+ " - "+Строка(Сост.Состояние)+"! Можно уволить после "+Формат(Сост.ПериодЗавершения, "ДЛФ=DD") , СтатусСообщения.ОченьВажное);
Отказ = Истина; // Запрет проведения
ИначеЕсли НЕ Сост.СостояниеЗавершения = Перечисления.СостоянияРаботникаОрганизации.Работает и Сотр.ДатаУвольнения < Сост.ПериодЗавершения Тогда
Сообщить("Сотрудник "+Строка(Сотр.Сотрудник)+" на "+Формат(Сотр.ДатаУвольнения, "ДЛФ=DD")+ " - "+Строка(Сост.Состояние)+"!", СтатусСообщения.ОченьВажное);
Отказ = Истина; // Запрет проведения
КонецЕсли;
КонецЕсли;
КонецЦикла;
ИначеЕсли ТипЗнч(Источник.Ссылка) = Тип("ДокументСсылка.КадровоеПеремещениеОрганизаций") Тогда
Для Каждого Сотр из Источник.РаботникиОрганизации Цикл
Сост=РегистрыСведений.СостояниеРаботниковОрганизаций.ПолучитьПоследнее(Сотр.ДатаНачала, Новый Структура("Сотрудник",Сотр.Сотрудник));
Если НЕ Сост.Состояние = Перечисления.СостоянияРаботникаОрганизации.Работает Тогда
Если Сост.СостояниеЗавершения = Перечисления.СостоянияРаботникаОрганизации.Работает и Сотр.ДатаНачала < Сост.ПериодЗавершения Тогда
Сообщить("Сотрудник "+Строка(Сотр.Сотрудник)+" на "+Формат(Сотр.ДатаНачала, "ДЛФ=DD")+ " - "+Строка(Сост.Состояние)+"! Можно переместить после "+Формат(Сост.ПериодЗавершения, "ДЛФ=DD") , СтатусСообщения.ОченьВажное);
Отказ = Истина; // Запрет проведения
ИначеЕсли НЕ Сост.СостояниеЗавершения = Перечисления.СостоянияРаботникаОрганизации.Работает и Сотр.ДатаНачала < Сост.ПериодЗавершения Тогда
Сообщить("Сотрудник "+Строка(Сотр.Сотрудник)+" на "+Формат(Сотр.ДатаНачала, "ДЛФ=DD")+ " - "+Строка(Сост.Состояние)+"!", СтатусСообщения.ОченьВажное);
Отказ = Истина; // Запрет проведения
КонецЕсли;
КонецЕсли;
КонецЦикла;
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 11800
 0 
Распечатать
Возможно, вас также заинтересует
Ввод данных по командировкам в программе ЗУП 0
Ввод сведений о командировках в программе 1С: Зарплата и управление персоналом 8 (ред.30) осуществляется в Разделе Кадры - Все кадровые документы - Создать - Командировка Откроется документ: Ввод сведений о...
Как в программе 1С Бух 3 отразить начисление фиксированных страховых взносов ИП? 1
Порядок расчета фиксированных страховых взносов за 2014 и 2015, 2016 год Сумма взноса в ПФР = МРОТ * 12 * 26 % Сумма взноса в ФОМС = МРОТ * 12 * 5.1 % где МРОТ (Минимальный Размер Оплаты Труда): 5554 рублей в 2014 году 5965 рублей в 2015
Как выбрать записи из регистра сведений? 1
//ВНИМАНИЕ !!! // В качестве полей для отбора могут задаваться измерения или реквизиты, для которых // в конфигураторе признак индексирования установлен в значение " Индексировать" или // установлен признак " Ведущее" ....
Как подключить Внешние печатные формы? 1
Начиная с 8-ой версии, в типовых конфигурациях появился очень удобный механизм подключения внешних печатных форм! Теперь можно сделать для каждой организации свои печатные формы и при этом совсем не меняя...
Как получить все начисления в ЗУП за указанный период? 0
В ЗУПе при разработке отчетов или дополнительного функционала, частенько требуется получить базу начислений за указанный период начислений: Запрос = Новый Запрос; Запрос.Текст = "ВЫБРАТЬ | ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.