helpf.pro
Регистрация
 0 
Распечатать

1С 8.2 УП : Как Свернуть, Развернуть узлы Дерева значений на форме?

Как программно свернуть/развернуть дерево значений на управляемой форме? Желательно &НаКлиенте.
Код 1C v 8.2 УП
  КоллекцияЭлементовДерева=ДеревоНоменклатуры.ПолучитьЭлементы();
//Свернуть дерево
Для Каждого Строка Из КоллекцияЭлементовДерева Цикл
ИдентификаторСтроки=Строка.ПолучитьИдентификатор();
Элементы.ДеревоНоменклатуры.Свернуть(ИдентификаторСтроки);
КонецЦикла;

//Развернуть дерево
Для Каждого Строка Из КоллекцияЭлементовДерева Цикл
ИдентификаторСтроки=Строка.ПолучитьИдентификатор();
Элементы.ДеревоНоменклатуры.Развернуть(ИдентификаторСтроки);
КонецЦикла;




Для выделенной, текущей строки:
Код 1C v 8.х
 // Разворот текущей строки в дереве:
Строка = ЭлементыФормы.ТабличноеПоле.ТекущаяСтрока;
ЭлементыФормы.ТабличноеПоле.Развернуть(Строка, Истина);

// Определим, развернут ли узел дерева в указанной строке.
УзелРазвернут = ЭлементыФормы.ТабличноеПоле.Развернут(Строка);
Если УзелРазвернут Тогда
// Если Развернут, то Свернуть
ЭлементыФормы.ТабличноеПоле.Свернуть(Строка);
КонецЕсли;


Код 1C v 8.х
  //перебором свернуть все Выделенные строки дерева Табличного поля
Для каждого Строка Из ЭлеменетыФормы.ТабличноеПоле1.ВыделенныеСтроки Цикл
ЭлементыФормы.ТабличноеПоле.Свернуть(Строка);
КонецЦикла;


Хотя конечно есть Ctrl+Shift+"+" и Ctrl+Shift+"-".

P.S. Для Табличного поля с галочкой Дерево(отображающего справочник), перебрать строки НЕВОЗМОЖНО!!!
Примеры вида:
Код 1C v 8.х
 Для каждого  Строка Из ЭлементыФормы.тпОбъекты.Строки Цикл
// или
Для каждого Строка Из ЭлементыФормы.тпОбъекты.ТекущаяСтрока.Строки Цикл
ЭлементыФормы.тпОбъекты.Свернуть(Строка);
КонецЦикла;
- НЕ РАБОТАЮТ!!!
Для СправочникСписок (ДокументСписок) итератора нет. Это не коллекция значений, перебрать не сможете. Дерево здесь ни при чем.
Можно работать со строками либо через ПриПолученииДанных (предпочтительнее по скорости), либо ПриВыводеСтроки.
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 26015
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.