helpf.pro
Регистрация
 +5 
Распечатать

1С 8.3 : Программное создание динамического списка для регистра сведений

Код 1C v 8.х
 &НаСервере
Процедура ИзменитьНаСервере(ИмяРеквизита)
// проверяем нужно ли создавать новый реквизит
Если Элементы.Найти(ИмяРеквизита) = Неопределено Тогда
МассивРеквизитов = Новый Массив;
// добавляем реквизиты
МассивРеквизитов.Добавить(Новый РеквизитФормы(ИмяРеквизита, Новый ОписаниеТипов("ДинамическийСписок"),,"Поле таблицы"));
// изменяем реквизиты формы
ЭтаФорма.ИзменитьРеквизиты(МассивРеквизитов);
// устанавлиеваем основную таблицу
ЭтаФорма[ИмяРеквизита].ОсновнаяТаблица = "РегистрСведений." + ИмяРеквизита;
// добавляем динамический список на форму
Элемент = Элементы.Добавить(ИмяРеквизита, Тип("ТаблицаФормы"), ЭтаФорма);
Элемент.ПутьКДанным = ИмяРеквизита;
Элемент.Видимость = Истина;
//добавляем колонки динамического списка
КолонкаКод = Элементы.Добавить("Код" + ИмяРеквизита, Тип("ПолеФормы"), Элементы[ИмяРеквизита]);
КолонкаКод.Вид = ВидПоляФормы.ПолеВвода;
КолонкаКод.ПутьКДанным = ИмяРеквизита + ".Код";
КолонкаНаименование = Элементы.Добавить("Наименование" + ИмяРеквизита, Тип("ПолеФормы"), Элементы[ИмяРеквизита]);
КолонкаНаименование.Вид = ВидПоляФормы.ПолеВвода;
КолонкаНаименование.ПутьКДанным = ИмяРеквизита + ".Наименование";
КонецЕсли;
// если реквизит создан ранее меняем его видимость на форме
Если ТекущийСписок <> ИмяРеквизита Тогда
// при первом выполнении, реквизита нет
Если НЕ ПустаяСтрока(ТекущийСписок) Тогда
Элементы[ТекущийСписок].Видимость = Ложь;
конецЕсли;
Элементы[ИмяРеквизита].Видимость = Истина;
// промежуточная переменная, для определения текущего списка
ТекущийСписок = ИмяРеквизита;
КонецЕсли;
КонецПроцедуры

&НаКлиенте
Процедура АдресныеСокращения(Команда)
ИзменитьНаСервере("АдресныеСокращения");
КонецПроцедуры

&НаКлиенте
Процедура АдресныйКлассификатор(Команда)
ИзменитьНаСервере("АдресныйКлассификатор");
КонецПроцедуры

Пример 

Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 5595
 +5 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
Блокировка записей, невозможно изменить или удалить из регистра. Конфликт блокировок MS SQL + 1C 1
При попытке удалить запись из регистра сведений - получаю ошибку: она заблокирована, ошибка блокировок и т.д. Отключил всех пользователей, перезапустил сервер, пробую удалить - опять ошибка блокировки :( Путем тестов...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.