helpf.pro
Регистрация
 +3 
Распечатать

1С 8.3 : Использование модальных окон в данном режиме запрещено! Модальные окна не работают, как быть?

В конфигураторе в свойства конфигурации, есть параметр «Режим использования модальности»

Режим использования модальности

Если установить Не использовать, то - принципе весь код, который после ОткрытьФормуМодально() Вопрос(), Предупреждение(), Выборов и диалогов открытия-сохранения станет работать с ошибками!


Рассмотрим пример с Использовать:

Код 1C v 8.3
 &НаКлиенте
Процедура КомандаВопрос(Команда)
Ответ = Вопрос("Ну что скажешь? ", РежимДиалогаВопрос.ДаНет);
Если Ответ = КодВозвратаДиалога.Да Тогда                                  
Сообщить("Ответили ДА!");                                              
КонецЕсли;
КонецПроцедуры

В режиме Предприятие получаем

Тест модального окна Вопрос

Если мы поставим Режим использования модальности = Не использовать то получим ошибку: Использование модальных окон в данном режиме запрещено

получим ошибку: Использование модальных окон в данном режиме запрещено

Теперь код нужно писать по новому:

Код 1C v 8.3
 &НаКлиенте
Процедура КомандаВопросПоНовому(Команда)
Оповещение = Новый ОписаниеОповещения("ОтветНаВопросЗавершение", ЭтотОбъект);
ТекстВопроса = "Ну что скажешь?";
ПоказатьВопрос(Оповещение, ТекстВопроса, РежимДиалогаВопрос.ДаНет);
КонецПроцедуры


&НаКлиенте 
Процедура ОтветНаВопросЗавершение(Результат, ДополнительныеПараметры) Экспорт 
Если Результат = КодВозвратаДиалога.Да Тогда
Сообщить("Ответили ДА");
КонецЕсли;
КонецПроцедуры

в результате

Почему 1С решила отказаться от использования модальных окон ?

В наш век развития мобильных технологий все идет к тому - что скоро все будут работать на планшетах и телефонах. 1С сделала для этого «Web Клиент» и «Мобильное приложение».  И чтобы успешно двигаться вперед нужно решать такие проблемы как, блокировка всплывающих окон. Ведь даже обычные браузеры по умолчанию блокируют модальные (всплывающие) окна!

Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 16712
 +3 
Распечатать
Возможно, вас также заинтересует
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
База 1С при запуске уходит в дамп и вылетает 1
В последнее время частенько обращаются пользователи у которых после замены или ремонта компьютера 1С не запускается, а точнее при открытии уходит в dump и вылетает. Как правило, решение одно: Отключить аппаратное...
В Книгу продаж по постановлению 1137 не попадают с/ф без НДС 3
Вопрос : Обновили бухгалтерию, появилась новая книга продаж, но счета-факутры без НДС в нее не попадают, а в старой книге продаж все отображается хорошо! Ответ : Без НДС заполняется только в двух случаях: 1. Дата...
Ввод по строке - поиск по первым символам или в любом месте наименования 0
При разработке конфигурации, для упрощении ввода документов потребовалось настроить ввод номенклатуры по совпадению любой части наименования! В 1С 8.3 по умолчанию настройки справочника номенклатуры такие: При...
Веб браузер в 1С используя поле HTML документа 0
Настраивал клиенту CRM, он захотел - чтобы панель управления сайтом была в 1С. Хочет - делаем: Обработка Веб браузер проста, состоит из поля HTML документа и 20 строчек кода: Код команд: НаКлиенте Процедура...
Посмотреть все результаты поиска похожих
Комментарии
DJ_Serega
30.09.2014 17:45Комментарий: 1
DJ_Serega

Имхо, было бы удобней, если бы формы для примера были в режиме "Компактности".

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.