helpf.pro
Регистрация
 0 
Распечатать

1С 8.3 : Как обновить форму списка из формы элемента?

Есть форма со списком элементов справочника. При нажатии на список открывается форма с элементом из списка, но при сохранении элемента первая форма не обновляется.

Как программно обновить форму списка?

В форме элемента необходимо написать код:

Код 1C v 8.3
 &НаКлиенте 
ПроцедураПослеЗаписи(ПараметрыЗаписи)
        Оповестить("ОбновитьФормуСписка");
КонецПроцедуры

а, в форме списка добавить событие:

Код 1C v 8.3
 &НаКлиенте 
Процедура ОбработкаОповещения(ИмяСобытия,Параметр, Источник)

        Если ИмяСобытия= "ОбновитьФормуСписка" Тогда 
                ЭтаФорма.ОбновитьОтображениеДанных(); 
        КонецЕсли;

КонецПроцедуры
Разместил:   Версии: | 8.2 УП | 8.3 |  Дата:   Прочитано: 8092
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
Ввод договоров ГПХ в ЗУП (счет 76) 5
Часто меня спрашивают: Как правильно отразить договор ГПХ в ЗУП? Ниже небольшая, последовательная инструкция: Прием на работу Сведения о физическом лице, выполняющем работы по договору подряда, должны быть внесены...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.