helpf.pro
Регистрация
 +1 
Распечатать

1С 8.3 : Краткий пример работы с OpenOffice.org Writer и Microsoft Office Word

Обработка демонстрирует простейший пример работы с 2-мя текстовыми процессорами - OpenOffice.org Writer и Microsoft Office Word. Нужно запустить файл обработки, в качестве шаблона она будет использовать файл "Primer.doc", который находится в одном каталоге с обработкой: Скачивать файлы может только зарегистрированный пользователь!

Файл Шаблона - Primer.doc:
От: {Организация}
Кому: {Контрагент}
Ждем акт сверки взаиморасчетов!
Директор /{Директор}/

Необходимо заменить в шаблоне ключевые слова в скобках {}, на указанные значения, вот примерный код обработки:
Код 1C v 7.x
 
//рдТаблицаЗамен - Таблица значений:
// {Организация} ООО "Контора"
// {Контрагент} ООО "Должник"
// {Директор} Дядя Вася
ПечатьИзШаблона(рдТаблицаЗамен, "Primer.doc");

// Функция преобразует Windows имя файла в URL OpenOffice
Функция ПреобразоватьВURL(ИмяФайла)
Возврат "file:///" + СтрЗаменить(ИмяФайла, "\", "/");
КонецФункции

Функция ОбработкаФайлаШаблона(ИмяШаблона) Экспорт

ИмяФайла = КаталогВременныхФайлов() + "doc.tmp";
Путь = ""; Имя = "";
ФайлОбработки = РасположениеФайла(Путь, Имя);

КаталогШаблонов = Путь;
ПолноеИмяШаблона = КаталогШаблонов + ИмяШаблона;

РезультатОбработки = 0;

// Проверка на существование
ЕстьШаблон = 0;
Если ФС.СуществуетФайл(КаталогШаблонов + ИмяШаблона) = 0 Тогда
Сообщить("Файл " + ИмяШаблона + " не найден в каталоге шаблонов печатных форм! Обратитесь к системному администратору!", "!!!");
Иначе
ЕстьШаблон = 1;
КонецЕсли;

// Копирование во временный каталог

Если ЕстьШаблон = 1 Тогда
ФС.КопироватьФайл(ПолноеИмяШаблона, ИмяФайла, 0);
КонецЕсли;

// Проверка копирования

Если ФС.СуществуетФайл(ИмяФайла) = 1 Тогда
РезультатОбработки = 1;
Иначе
Сообщить("Не удалось скопировать шаблон во временный файл.");
КонецЕсли;

Возврат РезультатОбработки;

КонецФункции

Процедура ОткрытьТекстовыйПроцессор(ИмяФайла, ТаблицаЗамен)

ТекПроцессор = рдТекстовыйПроцессор.ПолучитьЗначение(рдТекстовыйПроцессор.ТекущаяСтрока());

Если ТекПроцессор = "OOoWriter" Тогда

// Открыть OpenOffice

ServiceManager = СоздатьОбъект("com.sun.star.ServiceManager");
Desktop = ServiceManager.createInstance("com.sun.star.frame.Desktop");


Scr = СоздатьОбъект("MSScriptControl.ScriptControl");
Scr.Language="javascript";
Scr.Eval("Args=new Array()");
Args = Scr.Eval("Args");
Scr.AddObject("ServiceManager", ServiceManager);

// Откроем шаблон

ТекстовыйПроцессор = Desktop.LoadComponentFromURL(ПреобразоватьВURL(ИмяФайла), "_blank", 0, Args);

// Заменяем ключевые поля на нужные значения

Replace = ТекстовыйПроцессор.CreateReplaceDescriptor();

Для x=1 По ТаблицаЗамен.КоличествоСтрок() Цикл

Replace.SearchString = ТаблицаЗамен.ПолучитьЗначение(x, 1);
Replace.ReplaceString = ТаблицаЗамен.ПолучитьЗначение(x, 2);
ТекстовыйПроцессор.ReplaceAll(Replace);

КонецЦикла;

Иначе

// Открываем MS Office Word

Попытка
ТекстовыйПроцессор = СоздатьОбъект("Word.Application");
Исключение
Сообщить("Не удалось создать объект Microsoft Office Word!", "!!!");
Возврат;
КонецПопытки;

// Открываем шаблон

ТекстовыйПроцессор.Visible = 0;
ТекстовыйПроцессор.Documents.Open(ИмяФайла,, -1);
Fnd = ТекстовыйПроцессор.ActiveDocument.Range().Find;
Fnd.ClearFormatting();
Fnd.Forward = -1;

// Заменяем ключевые поля на нужные значения

ТаблицаЗамен.ВыбратьСтроки();
Пока ТаблицаЗамен.ПолучитьСтроку() = 1 Цикл
Fnd.Execute(ТаблицаЗамен.Найти,,,,,,,,, ТаблицаЗамен.Заменить, 2);
КонецЦикла;

ТекстовыйПроцессор.Visible = -1;
ТекстовыйПроцессор.Activate();

КонецЕсли;


КонецПроцедуры
//*****************************************************************************
Процедура ПечатьИзШаблона(ТаблицаЗамен, ИмяФайлаШаблона) Экспорт

// Проверим, есть ли нужный шаблон
Если ОбработкаФайлаШаблона(ИмяФайлаШаблона) = 0 Тогда
Возврат;
КонецЕсли;

ИмяФайла = КаталогВременныхФайлов() + "doc.tmp";

// Открываем в текстовом процессоре файл шаблона
ОткрытьТекстовыйПроцессор(ИмяФайла, ТаблицаЗамен);

КонецПроцедуры
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 15359
 +1 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 14
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через терминал, а еще у нее свой ноутбук и
1C: Enterprise Development Tools 48
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 1
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже веб-узла в э
Google maps : вывод точек на карту и режим панорамы 5
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С возможностью просмотра панора
Microsoft SQL Server Native Client Добавление значения в столбец "datetime" привело к переполнению 0
При формировании отчета на СКД получили ошибку: Microsoft SQL Server Native Client 11.0: Добавление значения в столбец "datetime" привело к переполнению Подробнее текст такой: ... по причине: Ошибка компоновки данных по причине: Ошибка получени
Посмотреть все результаты поиска похожих
Комментарии
favia
19.03.2020 06:23Комментарий: 1
favia

Добрый день! не совсем понятно. Заголовок указан для 8.3 код для 7.x обработка тоже для 7?

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.