helpf.pro
Регистрация

v8.2 УП: Суммировать количесвто

Ermak
23.12.2015 16:06Прочитано: 994

Подскажите как можно суммировать Количество заявок, чтобы потом проверить по условию.

Код 1C v 8.х
     Фильтр = Новый Структура();     
    Фильтр.Вставить("Маршрут",Маршрут);
    КоличествоЗаявок=РегистрыСведений.ЗаявкиНаПоставку.ПолучитьПоследнее(КонецДня(ДатаПоставки),Фильтр).Количество;
    Если КоличествоЗаявок > 5  Тогда
....
Yandex
Возможно, вас также заинтересует
Реклама на портале
IBReiter
23.12.2015 17:58Ответ № 1

Выбрать делайте, а не ПолучитьПоследнее

Ermak
23.12.2015 20:28Ответ № 2

А дальше как, можете показать на примере

E_Migachev
23.12.2015 20:31Ответ № 3

вот тут https://helpf.pro/faq/view/678.html

Код 1C v 8.х
 ВыборкаОКЛАД = РегистрыСведений.ПлановыеНачисленияРаботниковОрганизаций.Выбрать(Результат.Период,ТекДата,Новый Структура("Сотрудник", Результат.Сотрудник));
СумОкл=0;
Пока ВыборкаОКЛАД.Следующий() Цикл
СумОкл=СумОкл+ВыборкаОКЛАД.Показатель1;
КонецЦикла;
Ermak
24.12.2015 17:28Ответ № 4

Мне не выбрать надо а сложить Количество по Фильтру

Ermak
24.12.2015 18:56Ответ № 5

Сделал через запрос не работает, что не так, такое ощущение что не работает Период

Код 1C v 8.х
 	Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
              | ЗаявкиНаПоставкуСрезПоследних.Период,
              | ЗаявкиНаПоставкуСрезПоследних.Маршрут,
              | КОЛИЧЕСТВО(ЗаявкиНаПоставкуСрезПоследних.Количество) КАК Количество
              |ИЗ
              | РегистрСведений.ЗаявкиНаПоставку.СрезПоследних КАК ЗаявкиНаПоставкуСрезПоследних
              |ГДЕ
              | ЗаявкиНаПоставкуСрезПоследних.Маршрут =Маршрут
              | И ЗаявкиНаПоставкуСрезПоследних.Период МЕЖДУДатаНач ИДатаКон
              |
              |СГРУППИРОВАТЬ ПО
              | ЗаявкиНаПоставкуСрезПоследних.Период,
              | ЗаявкиНаПоставкуСрезПоследних.Маршрут";
Запрос.УстановитьПараметр("Маршрут",Маршрут);
Запрос.УстановитьПараметр("ДатаНач",НачалоДня(Дата));
Запрос.УстановитьПараметр("ДатаКон",КонецДня(Дата));


Результат = Запрос.Выполнить().Выбрать();  
Пока Результат.Следующий() Цикл  
КоличествоЗаявок=Результат.Количество;
КоличествоИтого=КоличествоЛгт+КоличествоЗаявок+Количество;
Если КоличествоИтого < 5 Тогда
........
Иначе
Предупреждение("Лимит изчерван!");
Возврат
КонецЕсли;
КонецЦикла;




Ermak
25.12.2015 08:43Ответ № 6
Вопрос закрыт!
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.