helpf.pro
Регистрация

v8: При создании Внутреннего заказа ошибка Поле объекта не обнаружено (Качество)

Reik
29.03.2012 11:25Прочитано: 2444
Помогите!!!
В "Управление торговлей", редакция 10.3 (10.3.13.2) Платформа 1С:Предприятие 8.2 (8.2.15.289)
При формировании «внутреннего заказа» на основании «Заказа покупателя» выдается сообщение об ошибке:
Код 1C v 8.2 УП
 Ошибка при выполнении обработчика - 'ОбработкаЗаполнения'
по причине:
{Документ.ВнутреннийЗаказ(868)}: Поле объекта не обнаружено (Качество)


В справочнике качество номенклатуры только одна запись "Новый"
Товар на складе есть!
В чем может быть причина????
Изменено 29.03.12 11:29:47
Yandex
Возможно, вас также заинтересует
Реклама на портале
Reik
29.03.2012 12:52Ответ № 1
Нашел в модуле Документа Внутренний Заказ строку на которую ссылается ошибка:
Код 1C v 8.2 УП
 
Для Каждого ТекСтрокаТовары Из Основание.Товары Цикл
Комплект = ТекСтрокаТовары.Номенклатура;
НаборЗаписей = РегистрыСведений.КомплектующиеНоменклатуры.СоздатьНаборЗаписей();
НаборЗаписей.Отбор.Номенклатура.Установить(Комплект);
НаборЗаписей.Прочитать();
Если НаборЗаписей.Количество()=0 ТОгда
НоваяСтрока = Товары.Добавить();
НоваяСтрока.ЕдиницаИзмерения = ТекСтрокаТовары.ЕдиницаИзмерения;
НоваяСтрока.ЕдиницаИзмеренияМест = ТекСтрокаТовары.ЕдиницаИзмеренияМест;
НоваяСтрока.Количество = ТекСтрокаТовары.Количество;
НоваяСтрока.КоличествоМест = ТекСтрокаТовары.КоличествоМест;
НоваяСтрока.Коэффициент = ТекСтрокаТовары.Коэффициент;
НоваяСтрока.Номенклатура = ТекСтрокаТовары.Номенклатура;
НоваяСтрока.ХарактеристикаНоменклатуры = ТекСтрокаТовары.ХарактеристикаНоменклатуры;
НоваяСтрока.Размещение = ТекСтрокаТовары.Размещение;
НоваяСтрока.Качество = Справочники.Качество;
КонецЕсли;
Для Каждого Стр Из НаборЗаписей Цикл
НоваяСтрока = Товары.Добавить();
НоваяСтрока.ЕдиницаИзмерения = Стр.ЕдиницаИзмерения;
НоваяСтрока.ЕдиницаИзмеренияМест = Стр.ЕдиницаИзмерения;
НоваяСтрока.Количество = Стр.Количество*ТекСтрокаТовары.Количество;
НоваяСтрока.КоличествоМест = ТекСтрокаТовары.КоличествоМест;
НоваяСтрока.Коэффициент = 1;
НоваяСтрока.Номенклатура = Стр.Комплектующая;
НоваяСтрока.ХарактеристикаНоменклатуры = Стр.ХарактеристикаНоменклатуры;
//НоваяСтрока.Качество = Справочники.Качество.Новый;
КонецЦикла;
КонецЦикла;


Если закомментировать строку(красным выделена), то ошибка не воспроизводиться.
Можно ли так сделать и не будет ли последствий??????
E_Migachev
29.03.2012 15:09Ответ № 2
(1) Reik, если не используете Качество в работе - то можно
Reik
29.03.2012 16:07Ответ № 3
Спасибо за ответ!
Пойду уточню у менеджеров
Reik
30.03.2012 10:11Ответ № 4
Качество не используют, всем спасибо!
Подсказка:Вы можете добавить любую страничку в Социальные закладки щелкнув по значку соцсетей (в вверху)
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.