helpf.pro
Регистрация
 0 
Распечатать

Табличное поле ~ Дополнительные колонки в динамическом списке

В процессе написания кода для отображения дополнительных вычисляемых полей в динамическом списке документов получились вот такие приемы (просто код, без комментариев).
Код 1C v 8.х
 Процедура ДокументСписокПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)
ТекДокумент = ДанныеСтроки.Ссылка;
СуммаДокумента = ТекДокумент.Товары.Итог("СуммаСНДС");
СуммаБезнал = ТекДокумент.Оплата.Итог("СуммаОплаты");
СуммаНал = ?(СуммаДокумента > СуммаБезнал, СуммаДокумента - СуммаБезнал, 0);
ОформлениеСтроки.Ячейки.СуммаДокумента.ОтображатьТекст = Истина;
ОформлениеСтроки.Ячейки.НаличнаяОплата.ОтображатьТекст = Истина;
ОформлениеСтроки.Ячейки.БезналичнаяОплата.ОтображатьТекст = Истина;
ОформлениеСтроки.Ячейки.СуммаДокумента.Текст = Формат(СуммаДокумента, "ЧДЦ=2; ЧН=");
ОформлениеСтроки.Ячейки.НаличнаяОплата.Текст = Формат(СуммаНал, "ЧДЦ=2; ЧН=");
ОформлениеСтроки.Ячейки.БезналичнаяОплата.Текст = Формат(СуммаБезнал, "ЧДЦ=2; ЧН=");

//Определяем наличие ПКО
Если ТекДокумент.ПолучитьОбъект().ПолучитьСвязанныйПКО() <> Неопределено Тогда
ОформлениеСтроки.Ячейки.ЕстьПКО.ОтображатьКартинку = Истина;
ОформлениеСтроки.Ячейки.ЕстьПКО.Картинка = БиблиотекаКартинок.ВыполненоУспешно32;
КонецЕсли;
КонецПроцедуры

Процедура ДокументСписокПриПолученииДанных(Элемент, ОформленияСтрок)
//Определяем наличие ПКО
МассивДокументов = Новый Массив;
Для каждого ТекСтрока Из ОформленияСтрок Цикл
МассивДокументов.Добавить(ТекСтрока.ДанныеСтроки.Ссылка);
КонецЦикла;
Запрос = Новый Запрос("ВЫБРАТЬ Основание ИЗ РегистрСведений.АА_СвязанныеДокументы КАК СД ГДЕ СД.Основание В (&Документы)");
Запрос.УстановитьПараметр("Документы", МассивДокументов);
Результат = Запрос.Выполнить().Выгрузить();
Для Каждого ТекСтрока Из ОформленияСтрок Цикл
Ссылка = ТекСтрока.ДанныеСтроки.Ссылка;
ТекСтрока.Ячейки.ЕстьПКО.ЗначениеКартинки = Результат.Найти(Ссылка,"Основание") <> Неопределено;
КонецЦикла;
КонецПроцедуры
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 8690
 0 
Распечатать
Возможно, вас также заинтересует
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 3
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
Быстрый отбор в справочнике по первой букве 0
В статье описан способ быстрой организации отбора в списке справочника по первой букве наименования. Механизм легко дотачивается под собственные нужды. https://helpf.pro/uploads/img/_1-T4ZDj6uNPX.png // ПРОЦЕДУРЫ И ФУНКЦИИ МОДУЛЯ ...
В регламентированной отчетности не печается штрих-код 1С ( EanGnivc ) 0
Установка шрифта EanGnivc В формах регламентированной отчетности, например, налоговые декларации, которые введены для предоставления отчетности, на всех листах в левом верхнем углу содержат свой уникальный штрих-код. В...
В чем разница между ОБЪЕДИНИТЬ и ОБЪЕДИНИТЬ ВСЕ в языке запросов 1С 2
Цитата из справки 1С: " По умолчанию при объединении запросов полностью одинаковые строки в результате запроса, сформированные РАЗНЫМИ запросами, заменяются одной . Если требуется, чтобы были оставлены разные...
Внешние обработки, печатные формы, обработки по заполнению табличных частей 2
Справочник «Внешние обработки, печатные формы, обработки по заполнению табличных частей» содержит список произвольных обработок, произвольных отчетов, дополнительных печатных форм, обработок для заполнения ТЧ...
Посмотреть все результаты поиска похожих
Комментарии
mixa4
17.12.2014 01:02Комментарий: 1
mixa4

вместо ЗначениеКартинки наверное ЗначениеФлажка

Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.