helpf.pro
Регистрация
 0 
Распечатать

Принудительная установка пароля пользователям, работающим без пароля!

Чтоб заставить всех, кто работает без пароля, установить пароль. Можно применить программный ограничитель. Для этого в модуле приложения добавляем функцию:
Код 1C v 8.х
 //am+
Функция ПроверитьИзменитьПарольПользователя()

ТекПользовательИБ = ПользователиИнформационнойБазы.ТекущийПользователь();
Если Не ТекПользовательИБ.ПарольУстановлен Тогда
ФВП = ПолучитьОбщуюФорму("ФормаВводаПароля");
ФВП.Заголовок = "Установите пароль на вход в 1С (не менее 6 симв.)";
ФВП.ОткрытьМодально();
Если ЗначениеЗаполнено(ФВП.Пароль) Тогда
Пароль1 = ФВП.Пароль;
Если СтрДлина(Пароль1)<6 Тогда
Предупреждение("Длина пароля должна быть не менее 6 символов!");
Возврат Ложь;
КонецЕсли;
ФВП = ПолучитьОбщуюФорму("ФормаВводаПароля");
ФВП.Заголовок = "Повторите новый пароль";
ФВП.ОткрытьМодально();
Если ЗначениеЗаполнено(ФВП.Пароль) Тогда
Пароль2 = ФВП.Пароль;
Если Пароль1<>Пароль2 Тогда
Предупреждение("Не совпадают пароли!");
Возврат Ложь;
Иначе
ТекПользовательИБ.Пароль = Пароль1;
ТекПользовательИБ.Записать();
Возврат Истина;
КонецЕсли;
Иначе
Возврат Ложь;
КонецЕсли;
Иначе
Возврат Ложь;
КонецЕсли;
Иначе
Возврат Истина;
КонецЕсли;

КонецФункции
//am-

и в предопредленной процедуре ПриНачалеРаботыСистемы (мы не можем использовать ПередНачаломРаботыСистемы т.к. в ней еще не существует окна программы и нет возможности открыть общую форму ввода пароля) делаем вызов
Код 1C v 8.х
 //am+
Если Не ПроверитьИзменитьПарольПользователя() Тогда
ЗавершитьРаботуСистемы(Ложь);
Возврат;
КонецЕсли;
//am-

источник
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 8989
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
17 правил для составления оптимального ЗАПРОСа к данным базы 1С 9
Для формирования и выполнения запросов к таблицам базы данных в платформе 1С используется специальный объект языка программирования Запрос . Создается этот объект вызовом конструкции Новый Запрос . Запрос удобно...
1C: Enterprise Development Tools 38
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 8
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 5
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Посмотреть все результаты поиска похожих
Комментарии
ip-my
17.02.2012 02:03Комментарий: 1
ip-my
Если не затруднит, дайте правильный код модуля формы пароля.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.