helpf.pro
Регистрация
 0 
Распечатать

Новый объект или нет - Как проверить в УФ?

В версиях 8.х достаточно было написать:
Код 1C v 8.х
 ЭтоНовый()   

В управляемом приложение проверка на Новый объект осуществляется так:
Код 1C v 8.2 УП
 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
ДокументОбъект = РеквизитФормыВЗначение("Объект");
Если ДокументОбъект.ЭтоНовый() Тогда
....
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 7527
 0 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Посмотреть все результаты поиска похожих
Комментарии
E_Migachev
28.12.2015 22:58Комментарий: 2
E_Migachev

Или так:

Код 1C v 8.3
  НаКлиенте
Процедура ПриОткрытии(Отказ)
         Если не ЗначениеЗаполнено(Объект.Ссылка) тогда
            Отказ=Истина;
            Форма = ПолучитьФорму("Справочник.НашСправочник.Форма.ФормаНовогоЭлемента",,этаформа);
            ОткрытьФорму(Форма);
    КонецЕсли;
КонецПроцедуры 
Vovan58
01.10.2012 15:12Комментарий: 1
Vovan58
или на клиенте :

Код 1C v 8.2 УП
 &НаКлиенте
Процедура ПриОткрытии(Отказ)
Если Параметры.Ключ.Пустая() Тогда

КонецЕсли;
КонецПроцедуры
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.