helpf.pro
Регистрация
 0 
Распечатать

Пытаюсь сделать расшифровку отчета

Пытаюсь сделать расшифровку отчета, в карточку счета хочу поставить отбор по своей номенклатуре, но проблема в том, что, в поле отбора встает слово номенклатура и моя номенклатура по которой я хочу сделать отбор, но оно будьто бы не доступно, сама карточка формируется без участия моего отбора. В карточке в доступных полях есть номенклатура, но выгружается туда в настройки номенклатура с красным крестом, в чем может быть дело?делаю так:
Код 1C v 8.х
 Если ТипЗнч(Расшифровка) = Тип("СписокЗначений") Тогда
Если Расшифровка.Количество() = 1 Тогда
ВыбранноеЗначение = Расшифровка[0];
Иначе
ВыбранноеЗначение = Расшифровка.ВыбратьЭлемент("Выберите расшифровку",Расшифровка[0]);
КонецЕсли;
Если ВыбранноеЗначение <> Неопределено Тогда
ВыбраннаяРасшифровка = ВыбранноеЗначение.Значение;
Иначе
СтандартнаяОбработка = Ложь;
Возврат;
КонецЕсли;
ИначеЕсли ТипЗнч(Расшифровка) = Тип("Структура")
ИЛИ ТипЗнч(Расшифровка) = Тип("Соответствие") Тогда

ВыбраннаяРасшифровка = Расшифровка;
КонецЕсли;

Если ТипЗнч(ВыбраннаяРасшифровка) = Тип("Структура")
ИЛИ ТипЗнч(ВыбраннаяРасшифровка) = Тип("Соответствие") Тогда

ОбщаяРасшифровка = Элемент.Область(1,1).Расшифровка;

Если ТипЗнч(ОбщаяРасшифровка) = Тип("Структура")
ИЛИ ТипЗнч(ОбщаяРасшифровка) = Тип("Соответствие") Тогда

Для Каждого Элемент Из ОбщаяРасшифровка Цикл
ВыбраннаяРасшифровка.Вставить(Элемент.Ключ, Элемент.Значение);
КонецЦикла;

КонецЕсли;

СтандартнаяОбработка = Ложь;

Отчет = Отчеты[ВыбраннаяРасшифровка["ИмяОбъекта"]].Создать();
Настройки = Отчет.КомпоновщикНастроек.ПолучитьНастройки();
Отчет.РежимРасшифровки = Истина;
ФормаОтчета = Отчет.ПолучитьФорму(, , Новый УникальныйИдентификатор());
Отчет.НачалоПериода = ДатаНач;
Отчет.КонецПериода = ДатаКон;
Отчет.Организация = ПостроительОтчета.Отбор.Организация.Значение;
Отчет.Счет = ПланыСчетов.Хозрасчетный.Материалы;
Отчет.Настроить();
Если ВыбраннаяРасшифровка["Отбор"] <> Неопределено Тогда
Для Каждого СтрокаОтбора Из ВыбраннаяРасшифровка["Отбор"] Цикл
Если ТипЗнч(СтрокаОтбора.Значение) <> Тип("Соответствие") Тогда
ТиповыеОтчеты.ДобавитьОтбор(Отчет.КомпоновщикНастроек, СтрокаОтбора.Ключ, СтрокаОтбора.Значение);
Иначе
Для Каждого Элемент Из СтрокаОтбора.Значение Цикл
ТиповыеОтчеты.ДобавитьОтбор(Отчет.КомпоновщикНастроек,Элемент.Ключ,Элемент.Значение);
КонецЦикла;
КонецЕсли;
КонецЦикла;
КонецЕсли;

ФормаОтчета.Открыть();
ФормаОтчета.ОбновитьОтчет();
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 3836
 0 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1Cv8.1CD - Файл данных достиг максимального размера! 3
1С выдает предупреждение " Файл данных достиг максимального размера" . Подскажите из - за чего это и как можно решить ? Превышен размер файла, обычно это сообщение возникает, когда размер файла 1Cv8.1CD приближается к 10...
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Комментарии
Altair
08.02.2013 16:42Комментарий: 1
Altair
А почему это в разделе FAQ?
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.