helpf.pro
Регистрация
 +3 
Распечатать

Как проверить ЭтоНовый() в управляемой форме?

Понятие ЭтоНовый() отсутствует в 8.2.
Поэтому при необходимости определить, что создается новый элемент можно использовать следующую особенность управляемой формы.
Как правило, любая управляемая форма содержит в себе реквизит "Объект", поэтому при интерактивном создании нового элемента, Объект.ссылка не заполнено!
Исходя из этой особенности, можем прописать приОткрытии() управляемой формы следующее:

Код 1C v 8.2 УП
  &НаКлиенте
Процедура ПриОткрытии(Отказ)
Если не ЗначениеЗаполнено(Объект.Ссылка) тогда
Отказ=Истина;
Форма = ПолучитьФорму("Справочник.НашСправочник.Форма.ФормаНовогоЭлемента",,этаформа);
ОткрытьФорму(Форма);
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.2 УП |  Дата:   Прочитано: 9768
 +3 
Распечатать
Возможно, вас также заинтересует
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
PostgreSQL: установка, настройка, обслуживание 2
PostgreSQL напрямую "из коробки" применяться для использования с 1С Предприятем не может. Необходима именно адаптированная версия от 1С, превращающая PostgreSQL в блокировочник, причем нужно понимать, что блокировки будут...
Посмотреть все результаты поиска похожих
Комментарии
all4cf
27.09.2016 00:53Комментарий: 3
all4cf

Последовательность событий, которые происходят при открытии формы нового элемента, можно представить следующей схемой:

Прежде всего, при заполнении нового объекта данными, можно попробовать обойтись вообще без написания какого-либо кода. Для этого у реквизитов объектов конфигурации есть свойства ЗначениеЗаполнения и ЗаполнятьИзДанныхЗаполнения.

Эти свойства позволяют визуально (в конфигураторе) задать правила, по которым реквизит будет заполняться данными при создании нового объекта.

Примеры кода:

Код 1C v 8.3
 &НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Если Параметры.Ключ.Пустой() Тогда //ЭтоНовый

КонецЕсли; 
КонецПроцедуры


&НаКлиенте
Процедура ПриОткрытии(Отказ)
//1С советует и тут использовать Параметры.Ключ.Пустой()
// но можно и так:
Если Объект.Ссылка.Пустая() Тогда //ЭтоНовый
//
КонецЕсли;
КонецПроцедуры
vat-74
04.07.2015 23:33Комментарий: 2
vat-74

Второй вариант проверки.

Код 1C v 8.3
 Параметры.Ключ.Пустая()   
natan43
26.07.2013 08:28Комментарий: 1
natan43
Хочу поправить автора. Метод ЭтоНовый() в 8.2 не отсутствует. Этот метод просто не доступен в тонком клиенте.
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.