helpf.pro
Регистрация
 +2 
Распечатать

Найти значение в Таблице Значений

Пример поиска НАЙТИ:
Код 1C v 8.х
 //Искать по всей таблице значений
НайденнаяСтрока = ТаблицаЗначений.Найти(ИскомоеЗначение);

//Искать в колонках Поставщик, Покупатель
НайденнаяСтрока = ТаблицаЗначений.Найти(ИскомоеЗначение, "Поставщик, Покупатель");

//еще
НайденнаяСтрока = ТаблицаЦен.Найти(ВыбТовар, "Товар");
Если НайденнаяСтрока = Неопределено Тогда
Предупреждение("Товар не найден!");
Иначе
ЦенаТовара = НайденнаяСтрока.Цена;
КонецЕсли;


Пример поиска НАЙТИСТРОКИ:
Код 1C v 8.х
 // Сформировать структуру отбора. 
СтруктураПоиска = Структура("Сотрудник", ИскомоеЗначение);
// Найти строки.
МассивНайденныхСтрок = ТаблицаЗначений.НайтиСтроки(СтруктураПоиска);

// .... ИЛИ
НайдСтроки = тзСхемы.НайтиСтроки(Новый Структура("Доставка", ОформлениеСтроки.ДанныеСтроки.Ссылка));
Если НайдСтроки.Количество() > 0 Тогда
ОформлениеСтроки.Ячейки.Схема.УстановитьТекст(НайдСтроки[0].Схема);
Иначе
ОформлениеСтроки.Ячейки.Схема.УстановитьТекст("Нет");
КонецЕсли;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 33082
 +2 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Посмотреть все результаты поиска похожих
Комментарии
sonGodv
12.05.2016 21:02Комментарий: 1
sonGodv

Ошибка в коде

СтруктураПоиска = Структура("Сотрудник", ИскомоеЗначение); [/pre]
СтруктураПоиска = Новый Структура("Сотрудник", ИскомоеЗначение); [/pre]
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.