helpf.pro
Регистрация
 +2 
Распечатать

Получение расшифровки для текущей ячейки СКД

Код 1C v 8.х
  //   “Результат” – поле табличного документа.

&НаСервере
Функция ПолучитьЗначениеРасшифровки(КодРасшифровки)
Если КодРасшифровки = Неопределено тогда
Возврат Неопределено;
КонецЕсли;

ДР=ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
КоллекцияПолей = ДР.Элементы[КодРасшифровки].ПолучитьПоля();

Если КоллекцияПолей.Количество() = 0 тогда
Возврат Неопределено
Иначе
Возврат КоллекцияПолей[0].Значение ;
КонецЕсли;
КонецФункции

&НаКлиенте
...
РасшифровкаЗначение = ПолучитьЗначениеРасшифровки(Результат.ТекущаяОбласть.Расшифровка);
...
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 5643
 +2 
Распечатать
Возможно, вас также заинтересует
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
Microsoft SQL Server Native Client Добавление значения в столбец "datetime" привело к переполнению 0
При формировании отчета на СКД получили ошибку: Microsoft SQL Server Native Client 11.0: Добавление значения в столбец "datetime" привело к переполнению Подробнее текст такой: ... по причине: Ошибка компоновки данных по причине: Ошибка...
Автоматическая установка ширины колонки табличного документа. 0
Процедура, которая " примерно" делает автоширину колонок (навроде, как если бы выделить все колонки и дважды щелкнуть мышкой по границе заголовка колонки). Привожу текст, работает неахти, но лучше чем ничего: Процедура...
Вертикальная автофиксация для СКД 0
В СКД очень не хватает возможности автофиксации строк. Обусловлено это невозможностью однозначно определить их количество в общем случае. Однако в большинстве случаев это можно сделать Обращаю ваше внимание, что...
Внешние источники данных 0
Почему данная возможность вызывает такой интерес? Любой человек, который программировал в 1С при этом достаточно неплохо знаком с SQL и хотя бы в общих чертах знаком с архитектурой и принципами разработки других...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.