helpf.pro
Регистрация
 0 
Распечатать

Как снять признак модифицированности?

Код 1C v 8.х
 Процедура НапечатанПриИзменении(Элемент)
Если Напечатан Тогда
КогдаНапечатан = ТекущаяДата();
Иначе
КогдаНапечатан = Дата(1,1,1);
КонецЕсли;
Если Модифицированность() Тогда
УстановитьПривилегированныйРежим(Истина);
ЭтотОбъект.Записать();
ЭтаФорма.Модифицированность=Ложь; //сбросили модифицированность
УстановитьПривилегированныйРежим(Ложь);
КонецЕсли;
КонецПроцедуры
Разместил:   Версии: | 8.x | 8.2 УП |  Дата:   Прочитано: 8007
 0 
Распечатать
Возможно, вас также заинтересует
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
Ввести перечисление, выбор перечисления 1
// В 8-ой версии нет такой фунции, но можно сделать так: ЗначПер=Перечисления.Важность.Средняя; //Установим перечисление предлагаемое выбрать по умолчанию Если ВвестиЗначение(ЗначПер,"Выберите важность:") тогда ...
Выборка (перебор) бизнес-процессов 0
Выбрать( , , , ) отбора отбора (необязательный) - Структура. Задает реквизит вида расчета и значение этого реквизита, по которому будет создана выборка. Ключ структуры задает имя реквизита, а значение структуры -...
Выборка (перебор) видов расчета 0
Выбрать( , ) (необязательный) - Структура. Задает реквизит вида расчета и значение этого реквизита, по которому будет создана выборка. Ключ структуры задает имя реквизита, а значение структуры - значение отбора по этому...
Выборка запросом, перебор задач 0
Выбрать( Отбор , Порядок ) Отбор (необязательный) - Структура. Задает реквизит вида расчета и значение этого реквизита, по которому будет создана выборка. Ключ структуры задает имя реквизита, а значение структуры -...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.