helpf.pro
Регистрация
 0 
Распечатать

Перевод из Десятичного в Двоичное и обратно

При разработке конфигураций, особенно если это обмен с сайтами или старыми системами учета, приходится переводить числа из одной системы исчисления в другую. Ниже примеры кода позволяющие выполнить данные функции перевода Десятичное в Двоичное и Двоичное в Десятичное:

Код 1C v 8.х
 Функция ДесятичноеВДвоичное(Знач ИсхЧисло) Экспорт
    
    ДвоичныйКод = "";
    Пока ИсхЧисло <> 0 Цикл
        ДвоичныйКод = "" + ИсхЧисло%2 + ДвоичныйКод ;
        ИсхЧисло = Цел(ИсхЧисло/2);
КонецЦикла;

    Возврат ДвоичныйКод;
    
КонецФункции

Функция ДвоичноеВДесятичное(Знач Стр2) Экспорт

Стр = СокрЛП(Стр2);
Рез=0;

Для н=1 по СтрДлина(Стр) Цикл
Рез=Рез*2+Число(Сред(Стр,н,1));
КонецЦикла;

Возврат Рез;

КонецФункции
Разместил:   Версии: | 8.x | 8.3 |  Дата:   Прочитано: 3162
 0 
Распечатать
Возможно, вас также заинтересует
Как перевести 36-ричное число в десятичное 0
create function base36_to_base10 (@base36 char(6)) returns char(10) as begin if @base36 is null return null if rtrim(@base36)=0 return  0 declare @base10 char(10) declare @ch char(1) declare @int int declare @bigint bigint declare @len
Как передать файл с сервера на клиент? 6
НаСервере Функция ПолучитьФайл() Двоичное=Новый ДвоичныеДанные(" C:файл.bmp" ); Адрес=ПоместитьВоВременноеХранилище(Двоичное,ЭтаФорма.УникальныйИдентификатор); Возврат Адрес КонецФункции НаКлиенте Процедура...
Технология восстановления удаленных объектов 2
Статья для версии 7.7, для 8.х смотрите - Битая ссылка, Объект не найден , Уникальный Идентификатор, GUID Введение Многие из Вас, наверное, сталкивались с такой проблемой как, удаление элементов в справочниках, а значит,...
Функция переводит Десятичное число в Шестнадцатеричное и обратно 2
// Функция переводит десятичное число в шестнадцатеричное // Параметры: _Число - Число - Десятичное число // Возвращаемое значение: Строка - Шестнадцатеричное число // Функция DecToHex(Знач _Число) База = 16; ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.