helpf.pro
Регистрация
 0 
Распечатать

Функция преобразования строки вида ДебиторкаПоКонтрагентам в Дебиторка по контрагентам

Примеры кода для 7 версии, но будут работать и в 8-ой

Код 1C v 7.x
  Функция мРазнПреобразоватьСтрокуСБольшимиБуквами(ИсходнаяСтрока) Экспорт

СтрокаВозврата = Сред(ИсходнаяСтрока, 1, 1);

Для Сч = 2 По СтрДлина(ИсходнаяСтрока) цикл
ПредСимвол = Сред(ИсходнаяСтрока, Сч - 1, 1);
ТекСимвол = Сред(ИсходнаяСтрока, Сч, 1);
СледСимвол = Сред(ИсходнаяСтрока, Сч + 1, 1);

Если ВРЕГ(ТекСимвол) = ТекСимвол тогда
Если ВРЕГ(ПредСимвол) <> ПредСимвол тогда
СтрокаВозврата = СтрокаВозврата + " ";
Если ВРЕГ(СледСимвол) <> СледСимвол тогда
ТекСимвол = НРЕГ(ТекСимвол);
КонецЕсли;
КонецЕсли;
КонецЕсли;

СтрокаВозврата = СтрокаВозврата + ТекСимвол;

КонецЦикла;

Возврат СтрокаВозврата;

КонецФункции // мРазнПреобразоватьСтрокуСБольшимиБуквами()


А таким кодом, просто перед большой буквой выставляется пробел:
Код 1C v 7.x
 
Список=новый СписокЗначений;
Для н=КодСимвола("А") По КодСимвола("Я") Цикл
Список.Добавить(Символ(н));
КонецЦикла;
Значение="ДебиторкаПоКонтрагентам";
Результат="";
Для н=1 По СтрДлина(Значение) Цикл
Сим=Сред(Значение,н,1);
Если Список.НайтиПоЗначению(Сим) <> Неопределено Тогда
Сим=" "+Сим;
КонецЕсли;
Результат=Результат+Сим;
КонецЦикла;
Сообщить(Результат);
Разместил:   Версии: | 7.x |  Дата:   Прочитано: 5181
 0 
Распечатать
Возможно, вас также заинтересует
10060 (0x0000274C): Попытка установить соединение была безуспешной 0
Установили новый терминальный сервер, на нем подняли 1С, терминальные пользователе неописуемо довольны, все просто летает :) И вот же надо было такому случиться, главному бухгалтеру не понравилось работать через...
1C медленно работает по сети с базой на SQL Server 8
Данное обстоятельство может быть обусловлено многими причинами. Одна из них - неоптимальная настройка MS SQL . Перечислим неоптимальности в настройке: 1) Неправильно указанный сетевой протокол, используемый для...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Посмотреть все результаты поиска похожих
Комментарии
basforum
16.08.2011 12:42Комментарий: 1
basforum
По 7.7 код абсолютно не правильный, надо примерно так
Код 1C v 7.x
 
сзСимволовБольшихБукв=СоздатьОбъект("СписокЗначений");
Для а=КодСимв("А") По КодСимв("Я") Цикл
сзСимволовБольшихБукв.ДобавитьЗначение(Симв(а));
КонецЦикла;
Результат=Лев(Стр,1);
Для а=2 По СтрДлина(Стр) Цикл
Сим=Сред(Стр,а,1);
Если сзСимволовБольшихБукв.Принадлежит(Сим)=1 Тогда
Сим=" "+Нрег(Сим);
КонецЕсли;
Результат=Результат+Сим;
КонецЦикла;
Сообщить("!"+Результат+"!");
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.