helpf.pro
Регистрация
 0 
Распечатать

Табличное поле ~ Как установить значения для новой строки

При добавлении новой строки нужно заполнить дату добавления и имя пользователя!

Добавлена строка может быть или кнопкой INS (добавление) или кнопкой F9 (дублирование).

При добавлении последовательность событий такая:

* ПередНачаломДобавления - строка еще не доступна

При дублировании последовательность событий такая:

* ПередНачаломДобавления - строка еще не доступна

* ПриАктивизацииЯчейки - строка уже доступна, но строка пустая.

* Повторная ПриАктивизацииЯчейки - строка уже заполнена. 

Как быть?

Для решения данной задачи необходимо использовать ПриНачалеРедактирования:

Код 1C v 8.х
 Процедура ОтчетПриНачалеРедактирования(Элемент, НоваяСтрока, Копирование)
Если НоваяСтрока Тогда
Элемент.ТекущиеДанные.Дата = ТекущаяДата();
Элемент.ТекущиеДанные.Менеджер = ПараметрыСеанса.ТекущийПользователь;
КонецЕсли;
КонецПроцедуры

В реалии это выглядит так, нажали добавить и получили:

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 4107
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1С 7.x : Как получить курсы валют с сайта НБУ http://www.bank.gov.ua/ за любую дату ? 2
Функция ПолучитьТаблицуКурсовНБУ(ДатаКурса, Ежедневно = 1) // если в качестве второго параметра указать число отличное от 1 - получем валюты, которые котируются на ежемесячной основе Перем Reader, Url, Точки, HtmlTab, Строк, Р,...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cклонения по падежам 4
НаКлиенте Процедура Команда1(Команда) ФИО = " Иванов Иван Иванович" ; Падеж = 2; Пол = 1; Результат = СклонениеФИО(ФИО, Падеж, пол); Сообщить(Результат); КонецПроцедуры НаСервере Функция СклонениеФИО(ФИО, Падеж, пол) ...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.