helpf.pro
Регистрация
 +1 
Распечатать

Вывод Структуры на печать в табличный документ

Многие спрашивают: Как вывести структуру на печать?

Путем простого перебора и вывода в табличный документ, вот пример:

Код 1C v 8.х
 	ТабДок = Новый ТабличныйДокумент;	
Макет = Справочники.Контрагенты.ПолучитьМакет("ПечатьСтруктуры");
ОбластьЗаголовок = Макет.ПолучитьОбласть("Заголовок");
ОбластьПодвал = Макет.ПолучитьОбласть("Подвал");
ОбластьДетальныхЗаписей = Макет.ПолучитьОбласть("Детали");

ТабДок.Очистить();
ТабДок.Вывести(ОбластьЗаголовок);
//Перебор СТРУКТУРЫ и вывод в Табличный документ. РК - Структура с данными
Для Каждого Элемент из РК Цикл           
//Сообщить(Элемент.Ключ + ": " + Элемент.Значение);
Если ТипЗнч(Элемент.Значение) = Тип("Структура") Тогда
Для Каждого ЭлементВ из Элемент.Значение Цикл 
ОбластьДетальныхЗаписей.Параметры.Заполнить(ЭлементВ); ТабДок.Вывести(ОбластьДетальныхЗаписей);
КонецЦикла;
Иначе
ОбластьДетальныхЗаписей.Параметры.Заполнить(Элемент); ТабДок.Вывести(ОбластьДетальныхЗаписей);
КонецЕсли;
КонецЦикла;
ТабДок.Вывести(ОбластьПодвал);
УниверсальныеМеханизмы.НапечататьДокумент(ТабДок); // или ТабДок.Показать();

Табличный документ

Разместил:   Версии: | 8.x |  Дата:   Прочитано: 4167
 +1 
Распечатать
Возможно, вас также заинтересует
Как заполнить табличную часть формы программно? 2
Нужно по кнопке Заполнить - сформировать данные для заполнения табличных частей и заполнить их. Форма имеет вид: Рядом с кнопкой Записать и закрыть добавлена кнопка Заполнить документ , код ее команды: // Код...
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
COM-подключение к базе 7.7 из 8.2 1С 4
Если код выполняется на стороне клиента, то необходимо наличие базы 7.7 на локальной машине. Пример (На форме объекта присутствует реквизит Таблица(ТаблицаЗначений)): НаКлиенте Процедура Загрузки() ПутьКБазе="...
Cообщение: "Не удалось удалить чеки ККМ!" 2
Пользователь с правами Администратор ККМ проводит Закрытие кассовой смены (Z). Выходит сообщение: " Не удалось удалить чеки ККМ!" ФР печатает Z -отчет, но Отчет о рознчничных продажах не формируется. Необходимо дать...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.