helpf.pro
Регистрация
 0 
Распечатать

Функция преобразует переданную сумму в строку вида 123 руб. 45 коп

Код 1C v 8.х
 //ПарСумма - сумма, число

//коп - Выводится всегда
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"ЧЦ=2; ЧВН=")+" коп."
КонецФункции

//Если копеек нет, то они и не выводятся
Функция РубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат " "
КонецЕсли;
коп = (ПарСумма-Цел(ПарСумма))* 100;
Возврат ""+Цел(ПарСумма)+" руб. "+?(коп>0, Формат(коп,"ЧЦ=2; ЧВН=")+" коп.","")
КонецФункции


//Пример обращения
Процедура КнопкаВыполнитьНажатие(Кнопка)
Сообщить(глРубКоп(ИтогоСумм)); //К примеру ИтогоСумм=875.05; - Результат 875 руб. 05 коп.
КонецПроцедуры



Код 1C v 7.x
 
// ПарСумма - сумма, число
//
// Возвращаемое значение:
// строка в виде: "ррр руб. кк коп."
//
// Описание:
// Преобразует переданную сумму в строку вида "ррр руб. кк коп."
//
Функция глРубКоп(ПарСумма) Экспорт
Если Число(ПарСумма)=0 Тогда
Возврат "руб. коп."
КонецЕсли;
Возврат ""+Цел(ПарСумма)+" руб. "+Формат((ПарСумма-Цел(ПарСумма))* 100,"Ч(0)2")+" коп."
КонецФункции

//Пример обращения
ИтогоСумм=875.05;
Сообщить(глРубКоп(ИтогоСумм)); // 875 руб. 05 коп.

Разместил:   Версии: | 7.x | 8.x |  Дата:   Прочитано: 7052
 0 
Распечатать
Возможно, вас также заинтересует
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
rphost занимает память и грузит процессор 12
У многих возникают проблемы с rphost.exe, разного вида: rphost занимает всю память rphost грузит процессор rphost жрет память причем 1С даже на запущена, а в диспетчере следующее: ежеминутно расчет на 2-3 мегабайта. Как быть и...
Битая ссылка, <Объект не найден>, Уникальный Идентификатор, GUID 21
Когда кто-то удаляет данные из базы без проверки ссылок на эти объекты, то везде где этот объект использовался появляется сообщение вида: Объект не найден (84:bf5600145e3710ab11dda4c605dbe824) . https://helpf.pro/uploads/img/_1-46z7I4U7Ww.png В
Ввод договоров ГПХ в ЗУП (счет 76) 5
Часто меня спрашивают: Как правильно отразить договор ГПХ в ЗУП? Ниже небольшая, последовательная инструкция: Прием на работу Сведения о физическом лице, выполняющем работы по договору подряда, должны быть внесены...
Ввод дополнительного ежегодного отпуска 0
Вид расчета, используемый для начисления оплаты дополнительного ежегодного отпуска , описывается в плане видов расчета Основные начисления организаций . Новый вид расчета удобнее создать копированием...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.