helpf.pro
Регистрация
 +1 
Распечатать

Как сделать фото на мобильном устройстве

Источник mobile-1s.ru

не забываем в свойствах конфигурации установить Требуемые разрешения "Мультимедиа"

Код 1C v 8.3
 

&НаКлиенте
Процедура КомандаСоздатьФото(Команда)

ДанныеФото = ПолучитьДанныеФотоСнимка();

Если ДанныеФото <> Неопределено Тогда
ТекущееФото = ДанныеФото.ПолучитьДвоичныеДанные();
Фото = ПоместитьВоВременноеХранилище(ТекущееФото, Новый УникальныйИдентификатор);
КонецЕсли;

КонецПроцедуры

&НаКлиенте
Функция ПолучитьДанныеФотоСнимка()

Данные = Неопределено;

#Если МобильноеПриложениеКлиент Тогда

Если СредстваМультимедиа.ПоддерживаетсяФотоснимок() Тогда

ТипКамерыДанные = ОбщегоНазначенияСервер.ПолучитьЗначениеКонстанты("ТипКамеры");
Если ТипКамерыДанные = ПредопределенноеЗначение("Перечисление.ТипКамеры.Задняя") Тогда
ТипКамеры = ТипКамерыУстройства.Задняя;
ИначеЕсли ТипКамерыДанные = ПредопределенноеЗначение("Перечисление.ТипКамеры.Передняя") Тогда
ТипКамеры = ТипКамерыУстройства.Передняя;
Иначе
ТипКамеры = ТипКамерыУстройства.Авто;
КонецЕсли;

РазрешениеВысота = ОбщегоНазначенияСервер.ПолучитьЗначениеКонстанты("РазрешениеВысота");
РазрешениеШирина = ОбщегоНазначенияСервер.ПолучитьЗначениеКонстанты("РазрешениеШирина");

//для устройств IOS этот параметр игнорируется
пКачество = ОбщегоНазначенияСервер.ПолучитьЗначениеКонстанты("КачествоФото");
Если пКачество = 0 Тогда
пКачество = 1;
КонецЕсли;

Если РазрешениеВысота <> 0 И РазрешениеШирина <> 0 Тогда
РазрешениеКамеры = Новый РазрешениеКамерыУстройства;
РазрешениеКамеры.Высота = РазрешениеВысота;
РазрешениеКамеры.Ширина = РазрешениеШирина;
Данные = СредстваМультимедиа.СделатьФотоснимок(ТипКамеры, РазрешениеКамеры, пКачество);

Иначе
Данные = СредстваМультимедиа.СделатьФотоснимок(ТипКамеры, , пКачество);
КонецЕсли;

Возврат Данные;
Иначе
Сообщить("Данное устройство не поддерживает фотоснимок!")
КонецЕсли;

#КонецЕсли

Возврат Данные;

КонецФункции
Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 1572
 +1 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.