helpf.pro
Регистрация
 0 
Распечатать

Как отсканировать штрихкод на мобильном устройстве

Источник mobile-1s.ru

//не забываем в свойствах конфигурации установить Требуемые разрешения "Мультимедиа"

Код 1C v 8.3
 
&НаКлиенте
Процедура ЗапуститьСканирование()

#Если МобильноеПриложениеКлиент Тогда
Если НЕ СредстваМультимедиа.ПоддерживаетсяСканированиеШтрихКодов() Тогда
ВызватьИсключение НСтр("ru='Сканирование штрихкодов не поддерживается';en='Barcode scanning is not supported'");
Возврат;
КонецЕсли;
ОбработчикСканирования = Новый ОписаниеОповещения("ОбработкаСканирования", ЭтаФорма);
ОбработчикЗакрытия = Новый ОписаниеОповещения("ОбработкаЗакрытияИнтерфейса", ЭтаФорма);
СредстваМультимедиа.ПоказатьСканированиеШтрихКодов(НСтр("ru='Наведите камеру на штрихкод';en='Aim the camera at an barcode'"), ОбработчикСканирования, ОбработчикЗакрытия, ТипШтрихКода.Линейный);
#конецесли

КонецПроцедуры


&НаКлиенте
Процедура ОбработкаСканирования(Штрихкод, Результат, Сообщение, ДополнительныеПараметры) Экспорт

пТовар = "";

Если Результат Тогда

Структура = ОбщегоНазначенияСервер.ПоискПоШтрихкодуОбъекта(ШтрихКод);
Если Структура = Неопределено Тогда
пТовар = Неопределено;
//#Если МобильноеПриложениеКлиент Тогда
// СредстваМультимедиа.ЗакрытьСканированиеШтрихКодов();
//#конецесли
Сообщение = "Не найден объект по штрихкоду " + Штрихкод;
Иначе
пТовар = Структура.Наименование;

Сообщение = сокрЛП(пТовар) + Символы.ПС + Штрихкод;

ДобавитьТоварВТаблицу(пТовар);

КонецЕсли;

КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ОбработкаЗакрытияИнтерфейса(ДополнительныеПараметры) Экспорт

//Если ЗначениеЗаполнено(пТовар) Тогда
// можем встроить код открытия формы ввода количества
//КонецЕсли;

КонецПроцедуры
Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 1723
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
1C: Enterprise Development Tools 35
И вот случилось долгожданное: Вышел 1C: Enterprise Development Tools - это среда для разработки конфигурации в IDE Eclipse. С сайта 1С: « 1C:Enterprise Development Tools » – это инструмент нового поколения для разработчиков бизнес-приложений систем
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Cодержимое указанного ниже веб-сайта в этом приложении блокируется... Aboutsecurity_1cv8c.exe 0
Проблема: После обновления на 1С:Бухгалтерию предприятия 3-й версии, при нажатии на закладку командного интерфейса 1С:предприятие, выскакивает ошибка: Aboutsecurity_1cv8c.exe или Aboutsecurity_1cv8.exe «Содержимое указанного ниже...
Excel файл как Внешний источник данных 4
Подключимся и загрузим из файла Excel данные в таблицу значений 1С. Сделать теперь это очень просто. 1. В конфигурации добавляет новый объект метаданных типа " Внешние источники данных" и назовем его просто " Excel" . ...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.