helpf.pro
Регистрация
 0 
Распечатать

Как вызвать альтернативный вариант сканирования штрихкода

Источник mobile-1s.ru

скачиваем с Google play Barcode scanner

Код 1C v 8.3
 
&НаКлиенте
Процедура ЗапуститьСканированиеBarcode()

#Если МобильноеПриложениеКлиент Тогда

НовВз = Новый ЗапускПриложенияМобильногоУстройства();
НовВз.Действие="com.google.zxing.client.android.SCAN";

Для Каждого Стр Из НовВз.ДополнительныеДанные Цикл

Если сокрЛП(Стр.Ключ) = "SCAN_RESULT" Тогда
Штрихкод = Стр.Значение;
//Сообщить(Стр.Ключ+" - "+Стр.Значение);

Структура = ОбщегоНазначенияСервер.ПолучитьОбъектПоШтрихКоду(ШтрихКод);
Если Структура = Неопределено Тогда
пТовар = Неопределено;
Иначе
пТовар = Структура.Номенклатура;

ОткрытьЗначение(пТовар);

КонецЕсли;
КонецЕсли;
КонецЦикла;

#КонецЕсли

КонецПроцедуры
Разместил:   Версии: | 8.3 |  Дата:   Прочитано: 1492
 0 
Распечатать
Возможно, вас также заинтересует
1C и Google Maps 12
была поставлена задача отображения на географической карте медицинских учреждений. После обзора предлагаемых решений был выбран сервис google. Но так же подобного рода подход будет работать и с картами сервиса yandex. Во...
Google maps : вывод точек на карту и режим панорамы 2
В отличие от яндекс карт в GMaps можно использовать панорамы - за что им большой плюс! Надеюсь в яндексе прочитают этот пост и тоже когда-нибудь это сделают! Для клиента нужно было сделать вывод объектов на карту С...
Google maps, поиск оптимального маршрута 2
В данном посте хочу коснуться основных аспектов построения оптимального маршрута с использованием API Google maps. Исходные данные для построения маршрута: * Географические координаты объектов, которые хранятся в базе; *...
HTML5 Canvas в 1С 8.3 или Google нам поможет 0
Добрался я для написания маленьких тестов для 1С в плане web графики. Версии 1С 8.2.61 и 8.3.3.641. Зайдем на http://www.w3schools.com/html/html5_canvas.asp и перенесем примеры в обработку 1С. Скачать обработку: Результаты не радуют. 1С в Intern
QR код в 1С 10
Столкнулся с интересной задачей реализации генерации QR-кода в 1С 8.2 ( QR-код — матричный код (двухмерный штрихкод) ) Для генерации было использовано api от google (http://chart.apis.google.com/chart). Вот сайт , который работает с ним. После...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.