helpf.pro
Регистрация
 0 
Распечатать

Как программно изменить проводку в Регистре Бухгалтерии?

Код 1C v 8.х
 //Необходимо изменить существующие проводки и добавить значение Субконто
Набор = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей();
Набор.Отбор.Регистратор.Установить(Объект.Ссылка);
Набор.Прочитать();
Для каждого Запись из Набор Цикл

Если Запись.СчетКт = ПланыСчетов.Хозрасчетный.ПрочиеРасчетыСРазнымиДебиторамиИКредиторами Тогда
// для переборов субконто
Запись.СубконтоКт[Запись.СчетКт.ВидыСубконто[1]] = Объект.ДоговорКонтрагента;
// указывая конкретное значение
//Запись.СубконтоКт.Договоры = Объект.ДоговорКонтрагента;
КонецЕСли;

КонецЦикла;
Набор.Записать();


Код 1C v 8.х
  // Перебор и замена реквизитов в проводках операции
НаборЗаписейБУ = РегистрыБухгалтерии.Типовой.СоздатьНаборЗаписей();
НаборЗаписейБУ.Отбор.Регистратор.Использование = Истина;
НаборЗаписейБУ.Отбор.Регистратор.Значение = ОперацияБух;
НаборЗаписейБУ.Прочитать();
Для Каждого ЗаписьБУ Из НаборЗаписейБУ Цикл
Если (ЗаписьБУ.СчетКт = ПланыСчетов.Типовой.ИндивидуальныйПодоходныйНалог) или
(ЗаписьБУ.СчетКт = ПланыСчетов.Типовой.СоциальныйНалог) Тогда

ВидСубк = ЗаписьБУ.СчетКт.ВидыСубконто[2].ВидСубконто;
ЗаписьБУ.СубконтоКт.Вставить(ВидСубк, Контрагент);

ЕстьИзменения = Истина;
КонецЕсли;
КонецЦикла;
Если ЕстьИзменения Тогда
НаборЗаписейБУ.Записать();
КонецЕсли;
Разместил:   Версии: | 8.x |  Дата:   Прочитано: 26338
 0 
Распечатать
Возможно, вас также заинтересует
1С Предприятие что это? 6
Что такое 1С? 1С — это фирма , у которой одно из направлений деятельности — разработка программного обеспечения для автоматизации бизнес-процессов предприятий. « 1С:Предприятие » - конкретный продукт, который...
Выбрать Остатки и Обороты по указанным счетам, отбор по субконто и выгрузка результата в EXCEL 0
Запрос=Новый Запрос; Запрос.Текст=" |ВЫБРАТЬ | ХозрасчетныйОстаткиИОбороты.Счет, | ХозрасчетныйОстаткиИОбороты.Субконто1, | ХозрасчетныйОстаткиИОбороты.Субконто2, | ХозрасчетныйОстаткиИОбороты.Субконто3, ...
Выгрузка и Загрузка проводок документа через файл 0
Процедура ВыгрузкаПроводок(Кнопка) Если Не ЗначениеЗаполнено(Документ) Тогда Сообщить(" Заполните поле Документ!" ); Иначе Движ = РегистрыБухгалтерии.Хозрасчетный.СоздатьНаборЗаписей(); ...
Выгрузка метаданных конфигурации в Microsoft Word и Excel 0
Перем ОбъектыКонфы; Перем СтруктКонфы; Процедура ВыгрузитьВWord() Попытка Word = Новый COMОбъект(" Word.Application" ); Исключение Сообщить(" Не удалось открыть Word" ); Возврат; КонецПопытки; Word.Documents.Add(); Документ = Word.Activ
Где в 1С указать ОКАТО? 0
в 1С:Бухгалтерии 2.0 заносится в справочнике " Организации" . В главном меню выберите " Предприятие" и зайдите в " Организации" . В открывшемся списке выберите вашу организацию. Когда форма организации откроется найдите...
Посмотреть все результаты поиска похожих
Вы не можете отправить комментарий анонимно, пожалуйста войдите или зарегистрируйтесь.